Wrong format when importing movie to MediaPlayer

This is most likely a problem with your UV’s of the TV. Make sure the UV shell for the display is square and takes up the whole grid. This is because when you preview the media file in the content browser it squishes the video into a square automatically.

So, I’ve just started working with UE4 and I want to have a video looped on a TV. Everything seems to work, but when I import my movie source file to the Media Player it plays in the wrong format, all zoomed in and squeezed. How can I change the settings so that the movie plays in the right format? Cheers!

Oh Alright. Thanks! Is there a quick way to fix the UV directly in Unreal? I made a model of the TV in Maya with a fixed UV map so I just assumed that it automatically would be right in UE4 to.

There’s no way to do it in UE4, you’ll have to do it in maya