Wrong editor UI scale in 4.18

After upgrading to 4.18 I instantly noticed that editor interface looks terribly over-sized, compared to 4.17

bumping it up.

The issue persisted into 4.19 preview for me. Filed bug report using new form. To get original editor UI scale roughly back to what it was in 4.17 and before, I need to set application scale to 0.8 in widget reflector.

Try adjusting Scale and Layout in Display Settings of Windows. I changed mine to 125% which works well for me.

That is exactly the problem. I do have mine set to 125%. At 100% it looks as it should. The issue affects not only UE4 but the launcher too.

Yeah, this is a problem for packaged games as well. Still no fix? It seems importantā€¦

You can adjust the Unreal Editor scale independently of the host OS display scaling.

Window | Developer Tools | Widget Reflector

Then find the ā€œApplication Scaleā€ adjustment and adjust it.

1 Like

It worked for me on v4.22

wow, yes the 3 lines of text fixed it, amazing. yet another setting location in the editor I would have never guessed was there.