Wrong currency and language in Epic Games Launcher

Good day,
I have problem with language in Epic Games Launcher and currency problem in Marketplace. The language and currency switched to russian, how can I switch it back to English language and USD as a default currency? I live in Ukraine.

You can change your desired language from the little global icon in the top right of the sign-in prompt screen. From there you can choose English.

I believe that the currency though is linked to you account settings, so you’ll have to change the country associated with your account.

Why would I want to change my country setting if I live in Ukraine? The currency is just wrong - russian rubles isn’t international currency by any stretch of imagination, and it’s definitely not used in Ukraine. This should be fixed on Epic’s side. The correct local currency is UAH. But I’d personally prefer seeing prices in USD.

Same here. Can anybody explain why currency setting is locked and is wrong? Even if you can’t add the currency of my country (sic.) why can’t I use USD for example?

Same for me, UAH or USD would be great

Same problem here, please set the currency to USD, i dont even know what are the prices on the marketplace, plus rubbles is not our national currency, it would still be converted for the transaction, so just make it USD…

I’m also can’t use RUB to see prices. Please make USD by default for Ukraine.

Same for me.
I live in Belarus and still see prices in russian rubles in the market…
The problem is that we even do not use russian rubles here.
Local currency is BYR, but it’s ok for prices in USD.

Sergey Galyonkin‏ confirmed that it is in progress.

There will be Hryvnia(UAH) as currency.