Wrong Camera View in Final Render

Hi everyone,

I am a fairly experienced user with the UE5 cinematic rendering pipeline, and I am here today because of an odd issue I’m experiencing when it comes time to render an animation of mine. I literally cannot find any info about why it may be happening, or how to fix it.

To help you understand why I have the things the way they are in this project, this is the setup:
I have a space station in the scene, and the space station is a blueprint where the “ring” going around the space station is rotating every tick. Attached to this ring is a “biodome” which has a landscape mesh + other features attached to it. This biodome is also within the blue print.

The goal for the animation is to have the “bone” mesh that you can see in the center of frame within the videos I have linked, rotate along with the blueprint, but be separately animated, since it would be a pain to animate within the blueprint. This is done by using a pivot point at the center of the ring, that pivots at the same speed as the blueprint. Therefore the bone mesh looks like it is part of the biodiome in order to make the mesh rise out of the dome and enter space in a natural way.

The bone mesh is parented to an invisible mesh, since it’s own pivot point was terrible (not my doing), then that invisible mesh is parented to the pivot point. Then, the camera is parented to the invisible mesh as well. This means the camera stays stably connected to the movement of the bone mesh while it whips around the space station at the same pace as the ring.

This ALL works perfectly fine in the sequencer (albeit without the ring moving since the level is not simulating.)

When I try and render through the movie pipeline, however, UE does not render the correct view through the camera, despite the correct/only camera being in the camera cuts track. UE also does not render the movement of the pivot point for the bone mesh. As you can see in the videos in my drive link, the bone mesh does not move with the station ring like it is animated to do so.

This is literally the end of this project, all I need is to render this baby out, and that would be it. However I can’t, because of this stupid problem. Can anyone help me figure this out? Why does the animation, which is clearly in the sequencer, and behaves normally during sequencer play back, not render correctly?

https://drive.google.com/drive/folders/1ZAobset9_2alpxeT_QBj64tjk5IvYVG8?usp=sharing

Literally about to lose my mind. Any help is appreciated greatly,
Chris

PS sorry for the video quality!

I have exactly the same camera problem, in the preview everything is fine as soon as I start recording it cuts out halfway through the sequence, or else the camera is not following the tracking shot planned for it and it goes into another meaning.

Glad I’m not the only one!
I’m beginning to think it may be a game mode issue. But, I’m not sure what settings to change to get things functioning. When I press play/simulate, I can see that the the game mode is spawning a separate camera. Not sure how to bypass, since to my understanding, the camera in the camera cut track should be the priority. Not sure why the game mode would be influencing the sequence animations themselves either!

Quick update! I managed to get the correct camera to render. Up until this point I was NOT using a master sequence. If you look in my render video you can see the render engine shot indicator reads “noshot [Cam01].” It occurred to me to ask why it said “noshot” when there clearly was one in the scene, so I created a new master sequence and added that sequence into the camera cut track. Now, my camera is rendering correctly.

However, the animation of the bone mesh is STILL not playing. I still am not sure why this is happening. REALLY need some help on this!