Wrong Camera View in Final Render

Hi everyone,

I am a fairly experienced user with the UE5 cinematic rendering pipeline, and I am here today because of an odd issue I’m experiencing when it comes time to render an animation of mine. I literally cannot find any info about why it may be happening, or how to fix it.

To help you understand why I have the things the way they are in this project, this is the setup:
I have a space station in the scene, and the space station is a blueprint where the “ring” going around the space station is rotating every tick. Attached to this ring is a “biodome” which has a landscape mesh + other features attached to it. This biodome is also within the blue print.

The goal for the animation is to have the “bone” mesh that you can see in the center of frame within the videos I have linked, rotate along with the blueprint, but be separately animated, since it would be a pain to animate within the blueprint. This is done by using a pivot point at the center of the ring, that pivots at the same speed as the blueprint. Therefore the bone mesh looks like it is part of the biodiome in order to make the mesh rise out of the dome and enter space in a natural way.

The bone mesh is parented to an invisible mesh, since it’s own pivot point was terrible (not my doing), then that invisible mesh is parented to the pivot point. Then, the camera is parented to the invisible mesh as well. This means the camera stays stably connected to the movement of the bone mesh while it whips around the space station at the same pace as the ring.

This ALL works perfectly fine in the sequencer (albeit without the ring moving since the level is not simulating.)

When I try and render through the movie pipeline, however, UE does not render the correct view through the camera, despite the correct/only camera being in the camera cuts track. UE also does not render the movement of the pivot point for the bone mesh. As you can see in the videos in my drive link, the bone mesh does not move with the station ring like it is animated to do so.

This is literally the end of this project, all I need is to render this baby out, and that would be it. However I can’t, because of this stupid problem. Can anyone help me figure this out? Why does the animation, which is clearly in the sequencer, and behaves normally during sequencer play back, not render correctly?


Literally about to lose my mind. Any help is appreciated greatly,

PS sorry for the video quality!

I have exactly the same camera problem, in the preview everything is fine as soon as I start recording it cuts out halfway through the sequence, or else the camera is not following the tracking shot planned for it and it goes into another meaning.

Glad I’m not the only one!
I’m beginning to think it may be a game mode issue. But, I’m not sure what settings to change to get things functioning. When I press play/simulate, I can see that the the game mode is spawning a separate camera. Not sure how to bypass, since to my understanding, the camera in the camera cut track should be the priority. Not sure why the game mode would be influencing the sequence animations themselves either!

Quick update! I managed to get the correct camera to render. Up until this point I was NOT using a master sequence. If you look in my render video you can see the render engine shot indicator reads “noshot [Cam01].” It occurred to me to ask why it said “noshot” when there clearly was one in the scene, so I created a new master sequence and added that sequence into the camera cut track. Now, my camera is rendering correctly.

However, the animation of the bone mesh is STILL not playing. I still am not sure why this is happening. REALLY need some help on this!

1 Like

Hey hey I know im late but I went into world settings and turned off “Enable Streaming” and that worked for me.

Man, I thought I had this figured out but alas my camera is now rendering from middle of map / some other position. Typically I had to convert camera to spawnable for it to even render correctly out of MRQ, and then make sure it was added in the top Camera Cuts layer. I was doing all of that and still, nothing, rendering from underneath the map.

Turns out there IS a difference between dragging in your camera actor into that top layer VERSUS going to layer +Camera > New Binding > find your camera actor. After that it started rendering correctly as I had for the other shots in my project, think I just duplicated a sequence and it didn’t have that actor in there by default.

I’m having an issue that seems related - my MRQ tracking shots are different than the ones I set up in Sequencer.

Sequencer (Note frame 722):

And now Movie Render Queue (Frame 723):

I’ve noticed that the Camera on the camera rig rail shoots far ahead of the vehicle when in MRQ. However, I started playing around with scalability settings and noticed that when I also put my viewport to Cinematic Scalability setting, it would sort of match what was going on in MRQ. I ran stat unit and can see that the camera starts shooting ahead of the vehicle whenever the GPU frame time is the limiting one.

So, I’m not sure how we’re supposed to ensure that our MRQ renders match up with what we set up in Sequencer when we have moving objects… if something as seemingly disconnected as a graphical setting or CVar can make the render turn out completely differently to the shot we set up. Or, even that the shot we set up changes within Sequencer itself…?

So, @LookIn2MyEyes1 since I had the same noshot indicator on MRQ, I also added my Level Sequence to a master sequence (imagining that Unreal might just auto-generate one where it’s missing, to package up a level sequence). When the new Master Sequence is made, it’s set to 30fps, so I changed that to 24FPS which I am also using for my Level Sequence. Wondering if this has anything to do with MRQ renders turning out differently?

But I also notice now that each time I play back the sequence in sequencer (whether from the Level Sequence Directly, or from the Master Sequence), it turns out differently. What is going on here??