Download

Wrong camera and no pawn control when joining listen server multiplayer session.

Hello.

Expected result:
I’m trying to get a client to join a lobby level. The host client and the joining client should both take control of one of the pawns and be able to move around. the camera should be top down.

What IS working
The Host can start the game fine and move around, the camera is in the right place. The only weird thing is that when I move it, it seems to play the walking animation on the other empty pawn (but that might be completely unrelated so nevermind that for now.)

What IS NOT working
When I get the client to join the game, it seems to, randomly, be using a first person camera at the position of the pawn it’s meant to be possessing. And the joining client can’t control its pawn either, it’s just stuck there staring from it’s first person camera. What is strange though is that I print a debug message to tell me who is controlling the different pawns, and it seems that my client IS controlling the TopWitch pawn, so maybe possession isn’t the problem here?

https://youtube.com/watch?v=tZ2p6rNitFs

**What I’ve tried. **
I tried using various different methods for possession, including setting the default pawn on the game mode instead of having the pawns already in the level, and tried spawning an actor onPostLogin then possessing it.
I’ve tested it in simulated multiplayer in editor and across a network with 2 machines.
I’ve tried using a switchHasAuthority node to make sure it’s just the server running the possession, but I think that just runs on server anyway.

LobbyBP.PNG

The is the start menu GameMode that comes before I start the lobby

startMenuBP.PNG

Would very much appreciate a bit of help. Thank you in advance,
Ashton

After fiddling this a bit more I’m pretty sure this is not a pawn possession issue. Even if I do nothing at all onPostLogin, the host will start the game with the correct camera and the client will start with the camera at 0.0.0