WorldInfo_0 Maps need lighting rebuilt

Hello all

i Have been using UE 4.15 for sometime .
and following some tutorials from the documentation and Created a landscape and then it showed that there objects need rebuilt so i press the “Build” Button but the same thing was showing so i tried to press “build lighting only” but same Message is still there .
so i took a look at output logs and find it Say WoroldInfo_0 Maps need lighting rebuilt searched for solutions on google but none of them worked .ve the

although i have lighting importance and post process

Sorry for my english

When you click on Build can you see the Swarm Agent running? You should have an icon through which you can open it and monitor its execution.

yes the Swarm is running when i press build
but when i press build lighting or build geometry the build message will show and close in no time

Do you have any log file to share?

Here is a very useful link with many tips to troubleshooting Lightmass. If you have a large open world, you may want to disable light pre-calculation altogether:…roubleshooting

how i can find log files ?

It is in the documentation I pointed you to here:

oh .
i will search and inform you .
but i tried to put static lights to 0 and then restarted the projects stuck at 39%
it’s not an open world project or anything
just the default map with a point light

Strange. It may be that something is wrong with your UE4 installation. I would try to reinstall it from scratch and try again.

because i am currently using 4.15 i think i would better install 4.18 instead of 4.15 ? but i am scared that it maybe it not work on my pc like 4.15

You can try to install 4.18 but keep 4.15 as well. You can have multiple versions of the engine on the same machine. Make a full copy of your project just in case. Convert the copy to 4.18 and check whether it works better. If it does, you can switch to 4.18 for good.

hello i just installed UE 4.18 bit when it load all thing look like that

That looks more like a locale problem. UE4 tries to use the Language/Local Settings from your operating system. You can switch to a specific language (English) under Editor Preferences -> Region & Language.

ok i fixed the squares in photo
now the build error is still here .

Ok try this. Create a new empty project. Open your current project, select your Level in the browser and Migrate it to the new project. All dependencies should automatically be migrated for you. Open the new project and check if you are able to build in it.