Download

World partition HLOD build map name

I trying this commandlet


But I can’t find the right form for the map name

The only way i could get it to work is by moving my project folder inside the folder where the editor was installed.

it now go forward but no HLOD are baked… so it might be bugged if someone managed to bake HLOd would be nice to hear about the process.

how map argument look like?

I try “E:\unrealEngine\UE_5.0EA\Engine\Binaries\Win64\UnrealEditor.exe” “C:\p4\Mag” “World’/Game/Maps/cityMap.cityMap’” -run=WorldPartitionBuilderCommandlet -AllowCommandletRendering -Builder=WorldPartitionHLODsBuilder
And I got this error

I too have not been able to get this to work. The CommandLine silently exits, even when provided with a -Verbose switch.

I’ve tried all kinds of combinations of full paths, with abd without .uproject and .umaps extensions. If the first parameter is anything but an absolute path to the .uproject file it will show you a log and give you an error… but once you provide that correctly no log at all is shown?

You don’t need to write the map path, you only need the map name with .umap extension, like this

E:\Gamedev\UnrealEngine\UE_5.0EA\Engine\Binaries\Win64\UnrealEditor.exe E:\Gamedev\UnrealEngine\Projects\UE5\WorldPartitionCity\WorldPartitionCity.uproject Demonstration_WP.umap -run=WorldPartitionBuilderCommandlet -Builder=WorldPartitionHLODsBuilder -AllowCommandletRendering -log=HLOD_log.txt

To speedup the process i have a batch file inside project folder like this:

@echo off
set UED=E:\Gamedev\UnrealEngine\UE_5.0EA\Engine\Binaries\Win64
set MAP=%1

%UED%\UnrealEditor.exe %CD%\WorldPartitionCity.uproject %MAP% -run=WorldPartitionBuilderCommandlet -Builder=WorldPartitionHLODsBuilder -AllowCommandletRendering -log=HLOD_log.txt

Where:

  • UED is a variable with the editor executable path
  • MAP is the parameter you pass to the batch file so the .umap map name
  • %CD% expand to the current folder so the project folder
  • -log=HLOD_log.txt save a log file under the \Saved\Logs folder

let’s say your batch file name is wpHLODcommandlet.bat and the map name is Demonstration_WP (like in my example) now i only have to run the batch with the map name as parameter, like this:

wpHLODcommandlet.bat Demonstration_WP.umap

1 Like

Thanks for the reply. Does this work for you on the current EAP Preview 2? I just tried building UE5 Main branch from source and everything worked for me there on first try.

Edit: The “-log=HLOD_log.txt” part was very helpful :slight_smile: With that I discovered the wrong editor binary was actually running which cause the tool not to work as expected.

1 Like

Update: Got it working just fine :slight_smile: it was a typical “stupid me” mistake where I was building a Debug editor build and then the commandline was running an ancient Development binary.

For anyone finding this thread, the commandline listed above from ZioYuri78 above works just fine :slight_smile:

1 Like