Download

World Machine to UE4 using World Composition

First off, I am totally new at this, so I apologize if I am missing something obvious.

I am following the wiki for importing world machine into UE4 at this link: https://wiki.unrealengine.com/World_Machine_to_UE4_using_World_Composition

I am new to both applications, which is obviously an issue for me :slight_smile: but I am able to get down to the part where we actually start importing into UE4.

In step 3 of ‘Terrain Material Setup in UE4’ it wants me to import the weightmaps I exported from World Machine. They had me export them as raw, but UE4 won’t import that type and I can’t just open them in gimp to rename them it seems.

Can someone get me moving down the right path again? I am using the latest version of both UE4 and World Machine (pro), and I am happy to fill in any detail that I can.

Thanks in advance,
Bob

Okay, you need to build the Material as instructed in the “Terrain Material Setup in UE4” step. The important part is to have all your weightmap layers linked in your material. You don’t need any images attached, you can work on that later, you just need the weight layers properly named (Rock Layer, Grass Layer, and so on) and all linked into one of the channels, usually the base color.

Then, when you get to the “Tiled Landscape Import” step, look at this image:

After selecting the material you made, a list of file fields will appear. (Listed as Low, Mid and High in the image.) This is where you choose the raw files you created. So for your Grass Layer, you would choose the RAW weightmap for the grass. Same with dirt, rock or whatever you export.

Hope this gets you on the right path!

Thank you much, I couldn’t figure out how to get to that menu, but it looks like my issue was more basic. I needed to turn on world composition and open that editor etc down the line.

I think I am good now, thanks for the help!

Ok, one more, same article if someone has time.

So my snags so far seem to be that the wiki page is out of date, understandable, it happens when things move forward. Well, not really as much out of date as it seems the workflow has changed, and the order is off.

I have everything loaded, and I think everything is done except one step (I have the steps after done as well).

In the Terrain Material Setup in UE4 section, bullet 10, it says to set the toling to 25. I don’t see a setting that is called or seems like it would be tiling. Any ideas how I set this?

Thanks again!
Bob

In

They mean in the Landscape Coordinate Node. (Nearly identical to the Texture Coordinate node, but works on the XY of a landscape, rather than the XY of a UV set.) You can set X & Y tiling there.

Thanks!

That is the the node I was using (Landscape Coordinate) but I think your reply game me enough information. It looks like they actually want you to set the Mapping Type to TCMT XY and then set the Mapping Scale to 25 as your starting point, and tweak from there.

Or at least that seems to work out how I would expect things to be :slight_smile:

Just a note: The usage of other Mapping Types can help you remove texture stretching by giving you another direction to map from. Example: On the side of a mountain, you can use XZ or YZ to paint from North/South or East/West to give you a better result that won’t get stretched when the landscape goes up very high, very fast. The only downside is that this required another level (or two) to your material to set up.

Nice, thanks for the tip!

Would you mind going into more detail, not quite sure how to set this up

In simplest terms, you need 3 Layers: a XY (Top/Down), a XZ (North/South) and a YZ (East/West).

Step 1) Import a texture into your material, then duplicate it twice, so you have 3 textures, one for each layer. (Be sure to set the Sampler Source to Shared: Wrap so it doesn’t severely decrease the number of textures you can use!)
Step 2) Create a Landscape Coords node for each texture, and connect them
Step 3) For the first one, set the Mapping Type to TCMT XY. For the second, set it to TCMT XZ, and set the third to TCMT YZ.
Step 4) Create three Landscape Layer Weight nodes. Name them however you wish.
Step 5) Connect the XY layer into the Base of the XZ Layer. Connect XZ to the Base of YZ. (It doesn’t really matter which order they are in though…)
Step 6) Connect the output of the final node into the Base Color (or whichever node you’re working on) and Apply/Save the Mat.
Step 7) Create/Open a Landscape with a sharp climb. Apply our new material to this landscape.

Now normally, when mapped, the images end up looking warped, because they are trying to apply from above and this creates stretching.

Step 8) Under Landscape->Paint, choose either your XZ or YZ painting layers.
Step 9) Paint over stretched materials to create a nice, smooth transition from the top map, to one (or both) of your side maps.

I had you create 2 side maps, because if you were to apply an XZ map to the side of a landscape that faces YZ, then you would see stretched streaking. Using an YZ map lets you paint over that, allowing for full 360 degrees of painting, with no stretching!

Thanks a lot, this is a tremendous help.

Hello! Ressurecting this as I have a different type of issue. In the material setup part, I followed every step to the letter but my material remains desperately black, anyone could tell me why? Below is my network.

7e03c4fc733797f0cd6fd0e423ea8d90ddeddb52.jpeg

Edit:

So, it SHOWS black in the preview windows inside the material editor but when I applied it via Import Tiled Landscape, it seems to work. Weird?

That is because the preview mesh doesn’t have a landscape layer on it. If you select any of your layers you will have the option to set its preview weight. Once you do that it will show up.

Thanks, that was right under my nose all that time :slight_smile: