World Composition using Multi-levels how do I stop all levels from being visible

I am making a very large game world with multi-levels(worlds) built in world composition, I have no problem setting up each large landscape (90 km x 60 km) using the world composition and placing each sub world into it’s own level. My problem is that even when I unload all other levels and only have one loaded, when I switch on game play the other levels are showing up overlaying the level I am on. I cannot seem to figure out how to have only the one level I am on showing on it’s own.

1 Like

I am hoping someone can eventually help me with this issue, as I still have not been able to resolve it yet.

I battled with this same issue, and here is how I think it is:

If your levels are sublevels of the Persistent level, there is no way to hide them in game when you are in world composition mode. Levels automatically become sublevels of your persistent level if they are in the same folder as the persistent level or in any subfolders inside the folder.

To see if they are sublevels: When you have your persistent level loaded, open your Levels-window - sublevels appear under the Persistent Level.

I might be wrong. So if someone finds a way, feel free to post it.


Thank you for the reply, I will look into this and was wondering if you have tried adding a Level BP into the Persistent level to sub-load/unload specific levels and linked them to a trigger event/box, as a work around.


Adding triggerboxes or events to the persistent level will not help if the levels are sublevels - they simply do nothing as sublevel loading is handled automatically by the engine based on streaming distance. Remember, that this only happens with world composition! If you turn it off, you can use triggerboxes normally Although in this case you might also have to change the streaming method for levels by right clicking the level in the levels window and change Select Streaming Method to Blueprint.

So, as far as I can understand, your only option is to disable world composition and change the streaming settings after that. I have no idea what disabling world composition does when you have imported tiled landscapes.

Unfortunately, that removes all the tiled landscapes, so it is not an option.

Actually, I found it. Doh, it was all in the documentation. The key is to make a new layer on world composition that has streaming distance disabled.

So, for those not familiar with the levels window:
You need to go to Window->Levels, then click on World Composition (the sheet with the check mark symbol), make a new layer by pressing the plus at top, then it prompts you for the settings. There you just disable the streaming distance. After that you need to right click a level on the levels window and assign the level to that layer.

That way the level streaming for those levels will not be automatic with world composition enabled.

Should have read the documentation a bit more thoroughly the first time…

1 Like

Thanks, that works!

Why oh why doesn’t it remember the state I left my world on and off? I have about fifty levels loaded in, and it turns everything off, loads nada. There are so many problems with this system.

I think you may be able to setup a starting BP that will auto load all the levels every time you open the project, I am looking into that for myself over the next few weeks, so if I figure it out I will let you know.

hah i had the oppossite problem, how to make the map big and have big drawing distance. “right click level on the levels window and assing level to that layer”. … . Thank youuuuuu!

Clutch. Thank you.

I believe to selectively load levels, we must change the setup of the folder hierarchy in the content browser. In other words, just put all levels you want to auto-load with world composition in the same folder as the persistent level, put the others in another folder.

I"m very new at WC, just having gotten my terrains to a state ( doing this manually,NO WC too expensive) and now I need to stop one of my terrains from "popping in’ drastically,its a real killer to the illusion of gaming :wink:

Is it a LOD issue, or so I want to turn streaming OFF to avoid that ?

My levels are already in the same folder as persistent so its not that.


Yes, you can do that, but depending on the size of your landscape and the power of your computer system that may slow your fps to a snails crawl.

Its bc, based on a video ON world comp by a UE4 dev , said the WC system hasn;t been either TOUCHED or not updated, in a very long time.
I can’t help but wonder, if its not even being used by enough people & or not bringing them enough revenue such that they aren’t dealing with it, hoping no one encounters errors.

As always it comes down to dollars and sense and what brings the money- if thats not it pls someone edify me/us.

I’m having the problem, where I KNOW, for sure , I have 4 separate terrains, , four separate landscapestreamingproxy(s) in world outliner, yet in world comp level window, there re only 3 distinct levels, clearly lying bc there are ‘4’ in the viewport, though ONE of them, while only ‘showing’ one in viewport , is somewhat ‘connected’ to a ghost level, meaning the level shows being connected to the one that shows up, via a ‘outline’, but doesn’t show up IN the viewport and also in the WC level window, there are two terrains that are ‘joined’.

I never did any such things. Bug city ?