World Composition - Landscape Z-axis

After enabling World Composition and importing my tiled landscape, I’m unable to move the landscape on the Z-axis. I’m also not able to rotate the landscape.

If I disable World Composition and manually add levels then I’m able to move the landscape on the Z-axis. If I then try to re-enable World Composition, the editor says I need to delete the levels I manually created.

Is there a workaround that allows me to move the landscape tile in World Composition on the z-axis? Or do I have to create a custom streaming solution? Any guidance would be greatly appreciated.

Hey guys, for anyone who has this issue, go to levels tab, click the butotn on top for Level Details, voilà! set position on any axis for each heightmap, you can select all at once and set a Z value.

Do no use the selection tool to move the landscape components, will bug out the brush, it will give a strange offset to the brush the higher the component offset.

1 Like

Hey mate! I tried your solution in 4.19.2 but there is no Z axis in level details. I wonder if there is a new solution for this?

if you talk about Position in Level Details - this is not for landscape, but for actors in the level - this option does not move the actual landscape ( well, i tried and only my meshes were moved and the land stayed at the same place)
Level offset from the zero world origin, stored as an integer 2D vector. All Actors in the level will be shifted by this value when the level is added to the world (becomes visible), and shifted back when the level is removed from the world (hidden).