World Composition 4.14. is using 6X as much Ram as in 4.12.5. HELP!

So yeah. Epic sadly broke World Composition in 4.14. I’ve done a full breakdown of the RAM usage on 4.12.5 vs. 4.14. so I can document the issue for the Epic staff to look over and fix. In short the same 64km2 map that took 3GB of RAM in Unreal 4.12.5 is now taking 18.5GB in Unreal 4.14.0. I’ve added documentation of the issue below. Does Epic know what could be causing the issue? Would really like to be able to take advantage of the World Origin rebasing that has been added in 4.14.

Here is the my PC’s memory usage BEFORE starting up Unreal. I have 20gb of RAM. You can see that I’m using roughly 50mb of ram at the moment. Very little ususage.

Here I’ve loaded up Unreal 4.12.5. You can see that Unreal is using 800mb of RAM. This is before loading anything else in the engine. The usage is really good in fact!

After loading up a 64km2 World Composition map this is our usage. You can see we’re using about 3GB of RAM with this 64gm Map loaded up. It’s very usable and easy to work with. Great job, Epic!

Here are the tiles as they look in World Composition. This is using up 3GB of RAM in 4.12.5.

Here I’ve loaded up Unreal 4.14.0. You can see that Unreal is using 900mb of RAM. This is before loading anything else in the engine. The usage is again really good!

Uh oh! After loading up the same 64km2 World Composition map in 4.14.0, you can see we’re using 18.5GB of RAM now! What the heck is going on?! This same 64km2 map only took up 3GB of RAM in 4.12.5.

Here are the tiles as they look in World Composition in 4.14.0. This is using up 18.5GB of Ram in 4.14.0.

We were planning on making the jump to 4.14. but this is a huge dealbreaker. Epic do you know what might be causing the issue?

Hi ,

I’m working on testing this now, but in the meantime I have a couple of questions:

  • Did you use 4.13 at all? If so, what was the memory usage like in 4.13?
  • Have you been able to reproduce this in a clean project by creating a few large landscapes and using world composition?

Thanks, and I’ll get back to you with the results of my tests soon.

Edit: After my tests, I didn’t notice a large difference in terms of how much memory was being used between 4.12.5 and 4.14.0 when working with a large world. As a result, this brings up one more question:

  • When you’re seeing increased memory in 4.14.0, is this will all of your sub levels visible? Were they all visible when you were checking the memory in 4.12.5?

Thanks again.

Hi and Sean!

I run in same probleme here, but maybe i found the bug and the workaround too…

First i opened my “empty” persistent level… You see the memoy usage

I Selected all my sublevels (4*4 landscape tile and 1 sub level for some models = 17 sublevel) and loaded all sub level with right click - load levels
After UE loaded my last sublevel, editor freeze and continue comsumpting memory… After a little time editor crash with out of video memory (I got R7 360 with 2 gb dd5)

I started investigate this… I tried to load every sub level separatly (not multi selected load) and see what happens? Memory usage is ok… GPU is still running i dont noticed error… Editor baked all of landscape texture…
Important thing i saved all my sublevels!!

After i saved all of my sublevel, i restarted the editor. Selected all of my sublevel and used “multi” load again…
Everything is fine, no memory leak, gpu still running…

I hope this help :slight_smile:

Hey ,

Thanks for the additional information. It’s interesting that you’re experiencing a crash, as I didn’t see that occurring on my end. Your memory usage also doesn’t seem abnormally high, as mine went up to as high as 20 gb of usage when I was testing in my project with no issues.

Could you test this using the in-editor memory tracker which can be enabled by going to Edit->Editor Preferences->Miscellaneous and enabling Show Frame Rate and Memory. You’ll see it appear on the top toolbar of the editor window.

If either of you are able to get a repro in a clean project please provide a detailed list of steps, as I’m not seeing the issue occur in a clean project on my end, meaning that I notice no difference between memory usage in 4.12 and 4.14.


Hi Sean!

I tested with a blank new project… No Crash, Memory usage is perfect… Everything seems me totaly ok… i can’t reproduce the “bug” Our project also perfectly working…

After i loaded sublevels separatly, saved and commitod to our repo, everything is fine… I can load every sublevel with one click, no weird memory usage… and everyone else in our team can use the map perfectly

I dont know what was that, maybe something from 4.13 to 4.14 upgrade what we dont saw… :slight_smile: