World comp issues

Current 4.22.3 working with just terrain nothing else, I’m getting weird distortions if that’s the word, one of my terrain tiles, as seen in world comp view, see below:!AvVOuPY0RaB5hekHg8nEAC5IQTHMgA
As seen on left one tile is very large and I did not create it that way as all tiles are precisely the same size or this wouldn’t work, ( although in play, depending where I am in world, large sections of playable world are invisible depending where I go in world ( likely streamed out ?), yet on the right, #3 is almost twice the size of the othes ( as on left side ) - what would have occurred to allow this,is this a bug or a wonkie value I have ( or none) I have for streaming ?
thx anyone

Check the level bounds (position,size). It’s in the world outliner, where all your meshes are. The level bounds decide about level streaming distances (at what distance a chunk is loaded/unloaded). It seems as if one of your level bounds is too large. Sometimes splines like long streets cause the level bounds to grow. But you can reset the size manually.

HM OK, I have : 556k, 374k, 662k, 374k,then a werid much larger last one at, 3,275,000 I can’t imagine I edited this as have no exact idea what it even DOES,so what should this last,huge one really be ?

Thx Bronislaw

The last one is for the world bounds. The values are ok and I wouldn’t touch it. Try to change the level bounds with the 662k to a smaller number and see, if it looks better on the map. You can double click the level bounds object and see how it looks like in your 3d world. If you want to set your own values, you should uncheck “auto update bounds”, so it will not use it’s own calculations. For keeping a clean level bounds size and layout it is important to give attention in which sublevel you place your splines and objects as it may influence the extent of the level bounds.

What doc page explains : " For keeping a clean level bounds size and layout it is important to give attention in which sublevel you place your splines and objects as it may influence the extent of the level bounds. "

High concenration on the opposite of question title as I have no game issues, just the ODD summons world comp window drawing issues, which has gotten a bit worse- so the idea of having to worry where you place objects as relates to level bounds extent is very alien to me,nor do recall seeing docs on it- how would I have known to be cautious when simply placing tile objects ?::slight_smile:

Pic originally show above on topic creation has changed, maybe posting here will make more clear what is going on, as not in above, now I see large amts of BLUE, and a few tiles are much larger.

What you see in the level composition are the 4 levels according to their level bounds. If you change the level bounds in a way that they fit their landscapes again, the blue parts should go away and the “tiles” become smaller, but it is not a glitch: It shows simply that the level extends into empty space or something like that.
Click just the yellow “reverse arrow” to the right of “scale” in the corresponding level bounds menu to reset the level bounds scale to default and see what happens, if you don’t like to see the blue parts. If it doesn’t work than there is something that prevents the level bounds from becoming smaller.

As for placing objects on the map or adding landscape tiles manually, it’s important to know which level is currently set as “active”. The active level is shown in the right bottom corner of your viewport screen.

I did that and no change occured on any scale reset- and what did youmean by level bound ‘menu’ ?

Level bounds menu is where you change the properties of your level bounds like scale, location, rotation. If it doesn’t work, check if there are some objects or tiles at the level bounds border, which prevent it from becoming smaller. From my experience esp. long connected splines cause the level bounds to grow. As last resort you will have to set the scale manually (uncheck auto update bounds) or leave it as it is if it causes no issues. Why are the four chunks separate or is it only for demonstration purposes of the issue ?
Here a visualization of my level bounds (of one sublevel):

HM, if I combine them by creating a DIR might that fix this ? I left them uncombined , as epic video on world comp didnt indicate not grouping wasn’t ok.
Your image didn’t come thru, its showing a broken icon?

Anyway, its not terribly hard working with , just a eye sore major , especially as I add more tiles, right now its just 2x2 as seen by pic.

I could see splines causing that as they are objects, but these are terrains seamlessly(ISH) sewn together–are we sure this isn’t a bug ,as I can’t seen this as a feature if its not working right.unless I select them all in world comp viewer and move together…I don’t know this part of ue 4 seems not thought out well- and we know this part of the code, is no longer being dev’d on–or so I understand.

Dunno , as you say, issues crop up as I never had these issues early on ,as I recall, with fewer tiles.
Ya they are seamed 100% fine, just separated to make comparison.

Now it should show my screenshot with the level bounds of one of my loaded sublevels.
Levels should be kept in one directory, because it looks cleaner. I’m going for huge worlds as well.

Maybe uncombined levels can cause glitches, because sometimes even I’m getting strange behavior like completely offset splines and objects when loading levels in a certain order or when I play with actors from certain sublevels, but I couldn’t reproduce it and whenever that happens I need to restart UE without saving, because it could destroy my level. The editor is not perfect or stable.

It’s good to restart from time to time to free RAM again (even with much RAM) and to prevent strange glitches that occur when the editor is open for a too long time.

It (too large level bounds) happened even to me with one level, but I suspect that my spline streets are causing this and I’ve to admit that even my world composition view looks unclean in some places now that I’ve looked into it more closely.
The best way then is to set the level bounds manually. You can even remove them completely and place new ones from the menu, where you get your meshes, lights etc.
Most people don’t even go for larger worlds and therefore they don’t encounter many of those glitches . If you “catch” a bug and can reproduce it then report it to Epic so they can have a look into it.

Nice glad not to be alone in this quest,the more use this feature its more likely issues will get closer look if any arise.
I’ll combine them to a DIR see what occurs.

Yes,on ram, atm just 8gb which for a while, is fine but out growing as of this writing LOL–Goal 32gb as they say after that no return,thinking on getting motherboard am4 -64gb, multi-taking alone mandatory. Its a bit crazy, my i5-570 IS outdated as my world grows,but its holding its own long as I don’t stretch too many settings to cinematic . Definitely going for multiCoreAMD RYZEN 7 3800X 8-Core 3.9 GHz (4.5 GHz Max Boost) Socket AM4 , just makes no sense to go lower as I’m gaining insufficiently to me anyway, for money spent.

Anyway ya restarting often is a good idea, and yes if I set bounds manually it does help, but the working Numbers are going to need some experimentation. Ya world comp is the only way given my adventure game features- areas in question are too vast for anything else for adequate presentation/realism.

Yes both get more involved with reporting as these issues can’t be normal, complicated sollutions and I’ll go back over docs to make sure I’ve not missed anything,a good epic youtube video never mentioned any of this so maybe its just what it is - youtube ue4 world composition - Bing video, this looks as good as any ,nice audio clear speak so I’ll see what he has to say.

Any suggestions on attached upgrade pic welcome .

Have a good one!