Download

Works runing on Chrome

Hi friends, I’m learning Unreal and I like to make works for windows and HTML5.

I did three jobs (for now) and these run fine (except ambient occlusion and reflection in HTML5). I must improve a lot but I’m very satisfied with UE.

Works run better in chrome:

AC Murcia hotel:
Windows: https://www.mediagenio.com/AC_Murcia_PC.rar
Online: https://www.mediagenio.com/acmurcia/room.html

Miscellaneous GOT:
Windows: https://www.mediagenio.com/Winter_is_coming_PC.rar
Online: https://www.mediagenio.com/winteriscoming/wic.html

The Roman Baths:
Windows: https://www.mediagenio.com/The_Roman_Baths_PC.rar
Online: https://www.mediagenio.com/theromanbaths/trb.html

I hope you like it,
Cheers!

Very Nice work.

However, online version is taking a very long time to load. Probably, you can look into it.

Can you give details regarding how did you manage to do the Online version?

Hi, thanks for your coment. Sorry for my english.

The long time to load is a great problem, I know it.
My hosting is “HTTPS”, here may be the error. I’m thinking on convert it to simple HTTP.

This is my setting in online versions with UE 4.8.3:

Packaging:

  • full rebuild: check.
  • Use pack file: check.
  • Include Prerequisites: check.
  • Include Crash Reporter: check.
  • Cook only maps: check.
  • Create compressed cooked packages: check.

HTML5 SDK:

  • Python27/python.exe
  • emscripten/1.30.0

I launch wiht Firefox x86 but, it runs fine in chrome.
The security browser system appears if I try to run it on Firefox, but I think it’s due to “HTTPS” protocol.

Thanks for your quick reply.

I tried building HTML5 and deploy. If I run HTML5LaunchHelper.exe I am able to run the project. If I place the packaged project in a server and try to access it, I am getting following error.

exception.png

Now, I am getting this error:
b3a16eda3424dd39a09db81a274a137ce9afbf85.png

Do you have any idea how to resolve this?

Hi MSL, maybe your scene is too big for x86 browsers. I also saw assertion and symbols errors when I launched works with 4.9 version.

All works released with version 4.9 failed. So I use version 4.8 only for html5 works.
Desktop works run fine with 4.9.

I don’t know if Epic resolved this issue with version 4.10.

You can use “Python” and “emscripten” in 4.8 but not in 4.9 version. All html5 works run fine with these two things in 4.8.

I understand Epic wants to be self-sufficient to not require these “helpers” but I see many users affected by the same problems with 4.9.

Looking good, all runs smooth on my machine with quite good loading times actually…One thing I’d suggest is to enable traditional movement controls: WASD :slight_smile:

Hmm… but surprisingly, it’s working locally if I use HTML5LauncherHelper.exe. Let me check with 4.8 version.

Yes, it runs locally with 4.9. The problems begin when you upload the work to your external server.

Thanks ULLS, i’ll change it for next works.

Ok. Now, it’s not building in 4.8 :mad:

ProjectLauncher.txt (20.7 KB)

I can package it for other platforms but if I try to package for HTML5 it’s opening HTML5 Documentation. So probably, some set up must have gone wrong. One thing I noticed is Location of Emscripten SDK is showing as Incorrect SDK Directory.
c8e2a929c909015b088cf09631b560dcccd3fbd9.jpeg

“Incorrect SDK directory” appears in my 4.8 version too, but no problem. The works run.

Be sure you Emscripten’s route is correct in your HTML5Engine.ini and it is “1.30.0” version (Program Files\Epic Games\4.8\Engine\Config\HTML5)

and add Firefox route in HTML5 devices (in your screem) :slight_smile: