Workaround if your VS 2017 is crashing mercilessly with VAX

Since the Microsoft Fall Creators Update, Visual Studio 2017 with Visual Assist X was crashing so badly from time to time. For me atleast the root of this problem was IntelliSense so only fix as of now is to disable IntelliSense and use VAX IntelliSense. Although you will lose some cool features of VS IntelliSense like Peek Definition, Toggle Header/Code file etc it is worth it because no more irritating crashes.

Follow the below steps and your life will be happy:

  1. Make sure you have Visual Assist build 2231 or newer. Parse times for UE4 solutions were greatly reduced in build 2231.
  2. Tell Visual Assist X that you are working with Unreal Engine 4 via this registry setting HKCU\Software\Whole Tomato\Visual Assist X\VANet15\EnableUnrealEngineC++ = 01
  3. Create a va_stdafx.h file in the directory of your .sln file. Put the following lines in the file, and make sure the file ends with a blank line. Replace YOURGAME with the name of your game:

#define ENGINE_API

  1. Make sure Visual Assist gets content for its enhanced listboxes from its own parsers, in VAssistX | Options | Enhanced Listboxes.

  1. Disable IntelliSense.

  1. Rebuild VAX symbol database.

  1. Restart Visual Studio 2017.


NOTE: Above information is from Visual Assist Docs.

I believed that i was the only one with this problem. Tried the solution but it takes a long time in “Loading solution projects…”

For me VS 2017 did not work after the fall update until I used the VS installer again and clicked “repair”. Then everything was fine again.

@ryanjon2040: the crashing of VS is likely caused by bugs in the FCU. Read more at

@DonFrag: Visual Assist needs time to parse all symbols in UE4 engine source the first time you open a UE4 solution. Make sure you have Visual Assist build 2231 or newer. Initial parse times dropped by 75% in build 2231. See What's New in Visual Assist - Whole Tomato Software