Workaround for Visual Studio 2017 hang when opening UE4.sln

Whenever I opened UE4.sln, Visual Studio 2017 would start, then hang for about 3.5 minutes before being usable. I had figured this was just due to the sheer size of the UE4 project, but it turns out to be a performance problem with the UnrealVS extension.

The problem was diagnosed by Microsoft in Dec 2018.

I’ve found two workarounds:

  1. Disable the UnrealVS extension
  2. Set the Visual Studio source control plugin to None

You just have to decide which one you’d rather live without. In my case, I don’t use the Git source plugin, so I went with option (2) so that I could continue to use UnrealVS.

To disable UnrealVS extension: Visual Studio 2017 > Tools menu > Extension and Updates… > UnrealVS

To disable the source control plug-in: Visual Studio 2017 > Tools menu > Options… > Source Control > Plug-in Selection, and then set the Current source control plug-in to None.

This problem isfixed. However, it is not yet in the latest public release (4.22) so you’ll either need the workaround or build UnrealVS from source.