Work From Home: How to use Unreal through Remote Desktop

UE4 can be used over Remote Desktop or other desktop sharing applications such as VNC. You must make sure that support for GPU acceleration is turned on to avoid using the ‘Microsoft Basic Render Driver’. For Windows 10, this can be achieved through the computer policies:

  • Open the Edit Group Policy tool from Control Panel or use the Windows Search dialog (Windows Key + R, then type in gpedit.msc)
  • Browse to: Local Computer Policy\Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Remote Session Environment
  • Enable “Use the hardware default graphics adapter for all Remote Desktop Services sessions”
  • Optional: You can also consider activating hardware encoding. The option is: “Configure H.264/AVC hardware encoding for Remote Desktop Connections”. It can also be done through the registry.…CODE_PREFERRED

Mouse Input: We recently fixed an issue with the handling of mouse inputs. This usually manifests while orbiting in the editor viewport. There is a shelved changelist for 4.24. (CL12393313)

Game controller support: The following explains how game controllers can be used over RDP. However, we heard that USB replication is only available in Windows 10 Pro.…sktop-session/

See more work from home tips!


The orbiting editor viewport mouse input bug is still present when using UE4Editor (4.24) remotely on Linux via a VNC client (e.g. on Ubuntu 18.04 with vino as the default VNC server on the server side).

The following patch can be used to add a new command-line option (-norelativemousemode) to the Linux build of UE4Editor so it can be used remotely with a VNC client:

diff --git Engine/Source/Runtime/ApplicationCore/Private/Linux/LinuxApplication.cpp Engine/Source/Runtime/ApplicationCore/Private/Linux/LinuxApplication.cpp
index 2eec72a6d18..ed18ad067ea 100644
--- Engine/Source/Runtime/ApplicationCore/Private/Linux/LinuxApplication.cpp
+++ Engine/Source/Runtime/ApplicationCore/Private/Linux/LinuxApplication.cpp
@@ -1362,7 +1362,10 @@ void FLinuxApplication::SetHighPrecisionMouseMode( const bool Enable, const TSha
        bUsingHighPrecisionMouseInput = Enable;
-       SDL_SetRelativeMouseMode(Enable ? SDL_TRUE : SDL_FALSE);
+       if (!FParse::Param(FCommandLine::Get(), TEXT("norelativemousemode")))
+       {
+               SDL_SetRelativeMouseMode(Enable ? SDL_TRUE : SDL_FALSE);
+       }

 void FLinuxApplication::RefreshDisplayCache()

Note that some VNC clients also have a problem with key press/release propagation in the editor viewport (most notably Remmina) limiting the ability to move in the viewport via keyboard. TigerVNC seems to be the one that propagates key press/release properly.


the Mouse input Problem is still a Thing.
is this Code als compatible with 4.26 preview?

Better try Parsec

in 4.26 the problem is solved the Flag is already integrated. before starting Unreal the Flag needs to be set.

I Still have the same issue here in Centos7 with Anydesk, it works ok in Windows did anyone get a solution for this?

So no solution? Really?

Hello im still trying to work this out. I am using 4.27 on a Linux Server via Remode Desktop Client. I found the No Relative Mouse Mode command-line in the Linux build.
It was mentioned that you have to “Set the flag”. Unfortunately I’m very new to all of this, so how/ where can I set this flag?

If anyone has the same problem:

You have to start the UnrealEngine from the Ubuntu Terminal but add -norelativemousemode .
Your command line should look somethign like
./ EpicGames/UnrealEngine/Engine/Binaries/Linux/UE4Editor -norelativemousemode

1 Like

I’m on Win 10 and have issues with the mouse ingame. When using the mouse to look around, if I continuously move it left or right, after some time the rotation locks and I cannot rotate further in that direction. I think that this happens as if the invisible cursor would try to leave the game window but got clipped to window size. Is there any solution for that? -norelativemousemode doesn’t fix it.

I have the same problem (the cursor stops at the screen edge). I’m using Microsoft Remote Desktop App for MacBook and UE5.2/5.3. Is there a solution for this?