Download

WM to UE4 Tiled World

Hi all. Still having a problem with this in 4.8 preview. It has always been the same and I haven’t found a fix for it yet.

Basically, importing a tiled terrain from WM always imports it wrong. You can flip it on the Y axis… but that is completely pointless as doing that makes your entire terrain flipped on the Y axis…

This is what I mean.
a50fae5966f92f9f3c77dc46170cbba4dda2ca93.jpeg

Obviously, I could go and flip things in Photoshop or whatever, but that would take forever. For each tile I would need to flip over 10 weightmaps, and on a massive landscape that’s say 40x40km… Yeah, it just wouldn’t be feasible.

So does anyone know how to go about fixing this?

Thanks in advance all!

World Machine -> World Commands -> Project World Parameters -> Tiled Build Options -> Flip Y-Axis Orientation

Yes… Like i said, that is completely useless as it flips the entire world when built. Making it completely backwards in UE.

I have it checked and haven’t had an issue.

I assure you, it doesn’t work correctly. Read my first post again.

In World Machine

In UE4

Problem occurs in all versions of UE.

I am not saying you are wrong, but I use the Flip-Y and it works for me. Are you setting your z-axis correctly in UE when importing(you need to do a calculation)
Can you show us a picture of your WM outputs? are you using a custom macro, bitmap outputs, or ??

It has nothing to do with the z axis, the z axis is just the vertical scale.

Flipping on the Y axis, does literally that.

Importing after flipping on the Y axis my import it in one piece but the entire map is flipped. The same thing happens if you use a single advanced perlin for generation, or the most advanced network you can imagine.

Here’s the setup im using to test the tiling. I used the layout generator to draw the coord’s on each tile and the border to show it matching up. If I flip on the Y axis, the 1’s are mirrored obviously. As you can see in my previous post.
b91098826039dd0b8c8bc050d3f706f2e1104445.png

Sorry to bump. But does anyone know a solution to this? How is it possible that this doesn’t work at all?

Cheers all!

Hi Thorax, the reason for this is that worldmachine and UE4 read the coordinates in different ways.

Try using a node called “Flipper” in your worldmachine file and then re-render with the same Y flip naming options enabled. Warning that flipper does have some problems with some other nodes. Those nodes usually have a little red warning symbol.

Thanks for the response RyanB.

Hmm… I have tried a flipper in the past but with no success.

I read on answerhub that this was filed as a bug and supposed to be fixed by 4.8. Could you possibly comment on that at all?

Thanks again. Really appreciate the help!

OK, so every single flipper has a red exclamation mark.

Here it is in World Machine

Here it is in UE4 when not using tiled import.

And here is the exact same terrain using tiled import

All the screen shots are taken from roughly the same location. (at least the same direction)

The landscape is just a random 2km area for the purposes of testing this out.

Here is the node network in WM. (It’s very basic as I am just trying to get this to work.)
5ad5f09928f5c19b432e49316b83bcc49e6f6b35.png

The UE4 Output Macro is only doing selections. Selecting slope, height and such, nothing fancy. The three erosion ones are just fed into an equalizer then a clamp and back out again.

Here is my Tiled Build Options window.
966d6e14d1fcace7a524859189b6edcee34f1d1c.png

I honestly have no idea what’s going on. It looks fine when not using tiled, but completely screwed up when I do.
I did wonder if it had something to do with the blending percentage.

Again, thanks everyone for any help. Its very much appreciated.

Again. Really sorry to bump. But can anyone shed some light on what is going on here?

It appears as though the weight maps appear as they should, but the landscape gets completely altered when using a tiled build.

Thanks in advance all!

I always set Blending percentage to 100%. I also uncheck “calculate edge tiles on…”
The only thing i can suggest is have someone else try to build your WM file and import it. PM me if you want me to try.

Still no difference.

Has anyone been able to do tiled world with weight maps?

No. To be honest the flipped node caused me too much grief as well.

Never told anybody this but the gdc kite demo landscape is flipped compared to what it was initially supposed to be, but I just rolled with it. This isn’t really a ue4 bug its more just an oddity of interface between UE4 and worldmachine. And worldmachines flipper node not working nicely.

Ahh I see. So you made the kite demo landscape? I didn’t know that.

I am aware it is a problem with WM I was more curious as to whether anyone here has experienced this problem.

Cheers anyway.

Yea, I suppose we could come up with a simple script or something that does batch-renaming of the files since that is really the culprit here.

That may work yeah.

The thing I find most odd though. Is that the elevation itself, without any weight maps involved, is completely different when using a tiled export.

It really depends on the terrain. I had another world that I was working on as an alternate backup and for some reason Tiled was causing things to move all over the place (rivers in wrong part of map etc). I seems to happen when doing lots of fancy blending using layout generators.

What if you increase the overlap settings in WM?

Overlap settings? Is that the tiled blending percentage?

EDIT: It looks to me that using any form of erosion and tiled building is a recipe for disaster. It just doesn’t work.
If you use erosion and blending when doing a tiled build, the terrain will end up looking nothing like what you expect.
Using blending at all completely changes the elevation of your landscape.

As far as I can tell, the only way to get it looking how you want is to not use any erosion or blending, and not flip it on the Y. Then batch rename the files as you suggested. I can’t see any other way of getting expected results.