Without t.MaxFPS my System crashes

I would really appreciate a preference setting to lock my viewport at 30 or 60 FPS. If I launch UE4 and forget to limit the FPS in the console, my GTX 780 runs wild rendering the viewport as fast as it possibly can, in the hundreds of FPS, and eventually crashes the system. I do lots of gaming, and and CUDA rendering on this card, and it is rock solid. The Unreal editor is the only piece of software that I have ever seen crash this card, and the whole system.

Also, I need some GPU for the other apps I am running. It’s kind of crazy that their is no preference setting to lock the viewport FPS. This is something I have to type into the console every time I launch the editor.

Hey Nerva-

EDIT: If you open the project Settings and check the General Settings under the Engine heading, there is a section for frame rate where you can set a desired frame rate range.


Have you tested that? Because it does not do at all what t.MaxFPS does in the console. It does not cap the viewport framerate at all.

if you want the editor to open with the default set to
MaxFPS = 30:


//under it write:

Hey , thanks a lot! That is exactly what I wanted! Works perfectly (editing the ConsoleVariables.ini).