Wireframe wires disappear when camera gets too close. How to fix?

Hey guys, newb here. Is there a way to stop the wire frame from disappearing when I get to close?

The problem here is that the wireframe isn’t being hidden, as such, but is simply behind your camera. I suppose you could change your FOV (in the Viewport options) to get a camera view that you find more useful.

I don’t remember having this problem before the 4.7.3 update. Changing the FOV is annoying but I guess it’s the only option I have until I find a better solution. thanks