Wired Animation bug. Not present when I eject or debug. Editor only!

Well, i made a video:

Can’t explain it better than the video, but i’ll try:
In the editor, my chickens have the idle animation all wrong, i think it interpolates half with the walk anim. I tried to debug it but when i do the bug goes away. Also, if i eject the bug goes away! It is like the Uncertainty Principle, when ever i look it changes!!! I am at a loss! Where to start ? Please help!

Set your idle on 0 right now it’s on 7.5 which probably causes it to interpolate when in idle state as you can see the bug seems to happen when they stop.

Well, it turns out that changing the blendspace from 1D to 2D solved the issue i had! I do not use the orientation, only the speed so i had blendspace 1D. However it caused the bug!

Yes, thank you! It is (was) 7.5 but it was 0, 30 and anything in between! Did not helped. With blendspace 2D it is fixed! somehow! i have orientation on horizontal at -180 and 180, and speed on vertical at 30. Guess i am not using 1D anytime soon.

Would be interesting to know if same would happen if you ticked “snap to grid” on the left for the animations. I had some weird stuff happen to me when my animation diamonds were yellow like that and snap to grid wasn’t turned on.