Download

WIP Villa

Hi, after seeing alot of great Archviz made in Ue4 it got me excited to try it for myself. So i bought a scene from ue4arch (They make great stuff!), and tryed to figure out how to get v-ray quality inside UE4. So this is my WIP of a Vila that i made. Still far from finished but its a start.

Not bad! There aren’t too many shadows though, you may want to play with the lighting and ambient occlusion a bit more. Keep at it. =)

Thanks for the advice. Trying to figure out how to get better shadows. I haven’t played around with the Ambient Occlusion in the world settings yet. Only in the post procces volume, but the results are a bit so so…

Is the Ambient Occlusion in the worldsettings tab better then the post procces volume? And would it impact the baking time a lot?

I’ve always used AO through the post processing volume. I’m not really aware of it’s impact on built times. To improve the shadows, maybe try playing around with the light placement.

Got some problems with my lightmaps now… When i’m walking around my lightmaps change LOD, got no idea how to fix this. I tried allot to fix this problem like turning on/off Compress lightmap. When on False. Most of my artifacts are gone but Lightmap mip map changing is horrible. My whole scene keeps changing LOD/mip maps. I also tried to change some ini settings to fix this issue like, LightmapStreamingFactor, ShadowmapStreamingFactor, PoolSize but no luck yet…

I’ll try to create an other movie on monday. Hopefully the problem would be fixed by then.

Hi, i updated the scene. I added some more details, increased the height of the ceiling. Changed some camera paths. And added 2 more rooms.

I fixed the changing of the lightmap LOD, when you record the movie there is a checkbox that will disable streaming of textures. I was wondering is there also a way to do this when you’r walking in realtime?

Wow. Very cool. FWIW in UE3 gamers always used to change the “bUseTextureStreaming=True” flag in the .ini files:

http://www.tweakguides.com/ME_7.html

I use -notexturestreaming in my scene because i’m way over textures memory budget and I hate popping. Loading the scene is a bit slow at 1st tho.

I noticed most people cameras move too fast. The high-end arch-viz movies always have a very slow pace so you can appreciate the architecture. I would run your matinee at .5 speed at least. :slight_smile: Other than that good job man!

Thanks for the feedback, you are right some scenes are going to fast. Need to fix that. About the -notexturestreaming is it set by code/blueprint? Or in an ini file?

launch parameter from the editor… Once compiled…probably in the config ini somewhere. Not 100% sure yet

Thanks that works great when set in the launch parameter! Just wat i was looking for. Now i can bake my lightmaps without an compression. Thanks again