Download

[WIP] Landscape

Hello everyone,

My first post here and my actually first project using Unreal 4.

First of all I am really new using Unreal 4, but I am eager to learn because I want to start using Unreal for architectural and engineering projects.

I have a massive terrain (something with 1320x1044 meters) that I want to show in a virtual tour. My problem so far is that when I import the terrain the player is huge. I tried to scale the terrain, but the player keeps huge.

I saw that using the blueprint Mycharater I can actually change the player size, but the difference is very small.

I do apologize for my newbie questions and I appreciate any help you can provide.

Many thanks,

Welcome! :slight_smile:

-Could you probably post a picture?
-do you use the landscape tool for the terrain?
-how have you made your terrain?
-make sure to use the right scale -> 1cm = 1uu

Just to go sure, should this be a WIP thread where you show what you are doing, or is it a “question thread” :wink:

Hi fighter5347,

First of all many thanks for the warm welcome.

I attached a top view and a perspective screenshot, so you can have a better look. The terrain initially was created in Civil 3D and then they exported a mesh which I imported into 3ds Max to clean a smooth the result. I am still “cleaning” this massive terrain and my goal is slowly introducing Unreal and show the potential to create virtual tours that will be needed.

The scale I am using in 3ds Max is cm and when I export the geometry I just follow the tutorial that explains how to export and import fbx files.

I also attached two more images explaining to show the difference of scale I am getting in Unreal while the “3dsMax” image shows what it looks on a correct scale (the player).

I want to show what I am doing, but at the same time I will have some doubts. Should I open a new thread (if there is nothing) every time I have a doubt or just keep asking for help using this WIP thread?

Many thanks once again.

It’s better when you start a new thread when you need help -> then it will be easier for others with the same problem to find the solution :slight_smile:

  1. I personally would use the landscape tool for a terrain → then place the meshes like stairs/buildings/… For that you can generate a heightmap in your 3d program which you can import (raw16) → this will give you the advantage that you already have a good LOD system + you can modify the terrain directly in the engine

Otherwise depending on the tri count of the mesh you will have to split it up + cull to get a good performance

  1. make sure that you also use cm in the export settings in 3ds max :wink:

What fighter said- turning that mesh into an image you can use:

You can do this two a few ways, one is to render out the depth buffer to an image in your 3D package. The second less accurate but quickest way is to apply a planar map on either the x or y with a gradient (material or texture). Render that out, import in UE4 as a height terrain.

Thanks fighter5347 and TimeSpirit for the replies.

I found out that I was in fact exporting a miniature landscape and I am still trying to export a heightmap that provides the same level of information I have on the mesh. The reason why is because the mesh as the roads+kerbs along with entrance to the buildings.

However, even if I import the terrain with the correct scale, the player is huge in comparison to the. I am definitely doing something wrong here. For example, I created a new project using the Vehicle Advanced template and import the terrain again. The truth is that when I try to place the PlayerStart I get the bad size error and this happens even if the position is really far away from the terrain as you can see in the image attached.

Update:

I tried Mudbox to create a heightmap, but the mesh has too much T-shapes and the heightmap failed several times. The same happened when I tried the suggestions mentioned by TimeSpirit the heightmap is not good because the mesh is a mess.

So, I went back to the first step and create a new scene where I imported the file with the mesh. Then I opened a new level in Unreal and imported the mesh again. So far so good, but when I click play the walk is not smooth at all. I don’t know if I can explain right, but the feeling is like trying to move in small jumps. Any solution for this problem?

Do you think as anything to do with the collision? Should I create a collision in 3ds Max and exported with the mesh?

It could be -> do you use the “use complex as simple” collision? https://www.youtube.com/watch?v=TTsAYpqHU-c

Hi fighter5347

When I never create a second mesh to be used as a collision. However, after using the Auto Convex Collision (I know that is not great for performance) the result is by far smoother. I also tried the use complex as simple and is working. Finally :smiley:

However, I still need your help to point me in the right direction. Although, I have a player start already in the scene, when I press the Play mode, it doesn’t behave like a first person, where you used the spacebar to jump and even the Q and E keys are working. Any chance I can get this working like a proper first person?

Many thanks for your help.

Use the fps blueprint template for the basic fps mode → after that you will have to add events like crouching, pickup,… :slight_smile:

e.g That’s how you can enable crouching:

  1. enable “can crouch” in your mycharacter bp settings

169e31c1137bf1849623222bae4fe3916a27ae70.jpeg

Thanks fighter5347 for your help. I think from the beginning the problem was the collision and now when I used a FPS template everything is working. The thing is that the small and rough presentation I did was approved and now everyone is really excited about what Unreal can do. :smiley:

I will keep updating this thread with new pictures and my progress