Windows: How to alter PATH of UE-Editor based on project settings

I’m developing on windows and have some really big third party libraries i’m working with which contain hundreds of DLLs and am looking for a way to avoid copying them locally to the project or any other UE default search paths but add their locations dynamically to the search path. This wouldn’t only save a lot of time but also much space.

Since i’m developing with VS, this can be easily done for all windows Solution Configurations by adding the needed paths to the debugging environment in the project settings on

“Configuration Properties->Debugging->Environment”,

f.e. like PATH=%PATH%;libPath1;libPath2

This works great for all windows builds (DebugGame, DebugGame_Editor, Development, Development_Editor) as long as i start the project from within Visual Studio.
But whenever i start the UE Editor manually (f.e. from the Epic Games Launcher) this doesn’t work because there’s no VS debugger environment which alters the PATH environment variable on the fly.

I’ve been trying out all sorts of .Build.cs properties like

  • PublicRuntimeLibraryPaths
  • RuntimeDependencies

but they don’t seem to affect a UE editor which is either running and tries to hot-relead a DLL or is freshly started without patching the PATH.

I could write a BATch which alters PATH and then starts the editor; or i could write a tiny plugin which patches the PATH-environment at runtime, but that all seems cumbersome and i’m hoping that i’m missing something obvious.

In “Third-Party Libraries” search paths are mentioned but it’s not explicitly stated if and how they could be altered.
Is there a way to

  • enable something that derives search paths automatically from .Build.cs, or
  • hard code them per project, or, at least
  • have a global setting somewhere which is read by the editor

so that i’m able to start the UE editor directly from the Epic Games Launcher and still have all search paths set up correctly?

When using the ProjectLauncher, i get the following error message during the deployment step:
Log.WriteException: AutomationException: Can’t deploy …dll because it doesn’t start with … or …

I found a maybe related problem here:
plugins residing outside Game or Engine don’t get deployed

Although the specified engine version is 4.2.6, this also happens with the V5 preview.