Download

Windows 10 remote build on mac failed due to private key permission

Hi Guys,

i’m looking for solution on this problem:


 

  1. LogPlayLevel: UnrealBuildTool: Compiling with iPhoneOS SDK 10.3 on Mac 192.168.1.xx
  1. LogPlayLevel: UnrealBuildTool: Warning: Identity file /cygdrive/C/Users/myUser/AppData/Roaming/Unreal Engine/UnrealBuildTool/SSHKeys/192.168.1.xx/myUser/RemoteToolChainPrivate.key not accessible: No such file or directory.
  1. LogPlayLevel: UnrealBuildTool: Permission denied, please try again.
  1. LogPlayLevel: UnrealBuildTool: Permission denied, please try again.

 

https://answers.unrealengine.com/questions/707368/remote-build-cygwin-permission-denied-on-windows-1.html

looking for solution anyone?

First things first. Did you generate the SSH key? And it completed successfully with no errors? Is that key file actually there?

yes the key is in place, generation is without problem. if i leave as it is with default permissions when i try to launch to iOS from engine i get warning your private key is accessible by other with some permissions like 0660 0440 bla bla… when i modify permissions i pass that problem and hit on this one… i tried with putty to connect to he remote iOS and it’s working so it’s something with permissions to the private key, engine and Windows 10 up-to-date with everything.

I’ve had other errors but not this one. Not sure what to do except make sure you’re an administrator and run Unreal as administrator while you generate the key? Check firewall settings?

tried running engine as admin before and after generating the private key…

look at the permissions

bumping… epic devs anyone help?

4.18 Changelog says that they supposedly made the remote build process easier. Fingers crossed for you.

tried preview one no help… will give a try on second preview.

Delete .ssh folder on your machine and run generation again from the engine.

The is how I solved the problem, I’ve already posted an answer in another post, I hope it helps you if you are having the same issues:
https://answers.unrealengine.com/questions/715773/chmodding-remotetoolchainprivatekey-for-ios-remote.html?childToView=735622#answer-735622

I solved this by copy the key in a path with no spaces like C:\Keys and set the “Override existing SSH permissions files” from remote build options to that path