Window sizing issue

I’m trying to create a HUD using the blueprint parent class selector, but the window is appearing too large for my machine. Is there any way to resize it so that I don’t have to constantly change the resolution of my machine JUST to look at the window?

Go to your editor preferences (Edit > Editor Preferences), the go to Level Editor > Play. There you will see the Play in editor and Play in standalone windows settings, you can set there the resolution you want the game to launch in.