Win64 Packaging Error: Missing UE4GameBinary

I am using a source version of UE4 4.15.1-release. I am unable to package my VR project for Windows. The error seems to happen in the last step of the packaging process. I have tried the following things:

  1. Rebuilding the engine
  2. Rebuilding the project
  3. Deleting the Intermediate and Saved folders
  4. Tried all three packaging configurations i.e Debug, Development, and Shipping; the outcome is the same in each case.
  5. Tried building my game in VS 2015, it builds fine under the settings Development and Win64. However, I need a package
  6. UnrealBuildTool closes immediately after I press F5 when it is set as the startup project in VS2015

The complete log is attached[link text][1]

Additional notes:

  1. I have been able to build Win64 packages for this project just fine when I was using a source version of UE4 4.14
  2. I have the FMOD plugin in my project too and this is placed in my game’s Plugins folder and not my Engine’s folder because FMOD does not work as an engine plugin anymore for UE4 4.15 due to Epic’s change with monolithic errors. I am not sure if FMOD is affecting the packaging process in some way.
  3. I am able to build packages just fine for PS4 for the same project

Any help will be greatly appreciated.

Hi KaranMonster,

Did you see the other AnswerHub that addresses this error? Missing Game Binary, cant pack a game on Win64 shipping mode

Particularly:

“We don’t automatically build the game executable for a content-only game, so part of using UE4 from GitHub means building the editor and building the base game executable (UE4Game). This is done by opening the generated Visual Studio project (usually found in the base directory where you downloaded the GitHub source) and building the UE4 project utilizing the Development configuration for Win64. That will build the executable and allow File|Package and Launch On to work. If you are building for a different platform (say Android), then you will want to specify the Android platform in Visual Studios platform drop down before building the executable.”

So I’m assuming you need to specify the VR platform in place of Android using the method described above.

Steve H.

I was able to resolve this yesterday. The problem was actually with the FMOD plugin.

Glad to hear you were able to find the source of the issue. Thanks for the update.