Win 7 UE 4.4.3 Closes during launch splash screen

Is there any word on when I should hear back from them?

Jaroslaw is looking into the issue for you now.

Drewseph, thanks for the files. What you’re seeing seems to be a rare problem - possibly related to a particular PC configuration - that I’ve seen posted by someone only once before.

Without further details on what exactly is crashing, it will be impossible to figure out what’s happening. Would you be able to build the Editor from the Github source code in Debug mode and assist me with debugging this problem?

In the meantime, to unblock you, please try disabling the UdpMessaging transport as follows:

  1. Open the file /Engine/Config/BaseEngine.ini in a text editor, i.e. Notepad

  2. Add the following lines at the bottom:

    [/Script/UdpMessaging.UdpMessagingSettings]
    EnableTransport=False

This will also disable some other features in the Editor, particularly UFE related functionality, such as profiling, but you won’t need that in the beginning. Hopefully we can figure out what’s going on.

Another thing you can try is this: if your PC is not connected to a wired network (i.e. only WiFi), please try connecting it by wire to a switch, router or internet gateway. Please let me know if that makes a difference, thanks!

gmpreussner ,

I’ll try to figure out how to get the source code. I’ve never done something like this though, but there’s always a first time. Is there a guide available on how to do this?

I’ll try those changes to the ini as soon as I get back.

I am not able to connect via wire to the internet, wifi is the only option here.

Ah ok, the reason I’m asking about a wired connection is because the only other user who also had this problem mentioned that he was connected through WiFi only, so this may be a good starting point for us to investigate.

Getting started with UE4 programming can take some time, but it’s definitely something you won’t regret learning. We have a guide on getting the source code from Github: https://docs.unrealengine.com/latest/INT/GettingStarted/DownloadingUnrealEngine/index.html

There is also a quick start guide for programmers: Unreal Engine CPP Quick Start | Unreal Engine Documentation

I added those lines to the BaseEngine.ini it still closes at the beginning of the splash starting screen.

okay I got it set up to build. However…

I get a failed build whenever I try to make one. Here’s the line it fails on.

1> [158/158] link.exe UE4Game-Win64-Debug.exe
1>LINK : fatal error LNK1181: cannot open input file ‘libovr64.lib’
1> -------- End Detailed Actions Stats -----------------------------------------------------------
1>ERROR : UBT error : Failed to produce item: C:\Program Files\Unreal Engine\Github\Engine\Binaries\Win64\UE4Game-Win64-Debug.exe

The libovr64.lib seems to be in the Oculus folder, oddly enough.

I think you’re missing the third party library package. The details are on the GitHub page itself - check the “Getting up and running” section here: https://github.com/EpicGames/UnrealEngine

Required_1of2.zip and Required_2of2.zip is what you need.

We are also still trying to repro the problem in our office, but so far haven’t been able to. Hopefully we can get you up and running with VisualStudio.

The just keeps getting weirder. I was double checking to see if I had the third party plugins installed for my own local editor build and decided to try once more to launch the editor from:

C:\Program Files\Unreal Engine\4.4\Engine\Binaries\Win64\UE4Editor.exe

Low and behold the editor launched and made it to the projects setup page and opened the default project. I messed around in it and saved it. Closed the editor and launched the editor again from Unreal Launcher, and it still worked.

After playing around some, I closed the editor a second time. When I returned to my computer a few minutes later (I did not restart or put the computer to sleep), the editor vanishes again on booting up. I cannot get back into the editor from the exe, OR the launcher.

I can however go directly to my saved project in my documents, and run the editor from there with 100% success.

Are you able to reproduce the startup crash with a version of the Editor that you built in Visual Studio? That’s all that matters right now, because we need Visual Studio to debug the crash. If we can get at least a callstack, that would be a good start :slight_smile:

I’ve made sure I have all those third party plugins installed. I’m meeting all the correct files installed but I still cannot get a build to succeed.

what’s the error?

The error hasn’t changed, its still :

1> [158/158] link.exe UE4Game-Win64-Debug.exe 1>LINK : fatal error LNK1181: cannot open input file ‘libovr64.lib’ 1> -------- End Detailed Actions Stats ----------------------------------------------------------- 1>ERROR : UBT error : Failed to produce item: C:\Program Files\Unreal Engine\Github\Engine\Binaries\Win64\UE4Game-Win64-Debug.exe

Have you tried these:

https://answers.unrealengine.com/questions/88405/how-to-build-a-game-from-source-build.html

https://answers.unrealengine.com/questions/85773/compile-error-with-latest-44-branch-from-github.html

That second one seemed to do do the trick, however it was the answer with 12 upvotes that worked, rather than the accepted answer. I was able to successfully build a Debug Editor build that way, but trying to open UE4Editor-Win64-Debug.exe crashes on the grey splash screen still.

That’s great - it will allow us to debug the crash. Could you please copy and paste the callstack from Visual Studio?

Also, would you be able to meet me in the IRC chat channel at some point in case we have to dig into this further? That might be faster than trying to do it here:

http://webchat.freenode.net/
Channel: #unrealengine
My nickname is Epic|j3rky

We tracked this down to be caused by AntiVirus software called Symantec PC Tools. This also prevented debugging from working in Visual Studio. After uninstalling and rebooting the computer, everything worked again.