Widgets broken in packaged builds in 4.17 and 4.18

Hi all,

Some of my widgets are getting really strange behaviour in my packaged games, everything works great in editor and standalone, also it worked well in 4.15. But since I updated the engine, when I compile, my packaged version is not working properly. Some of the errors I get:

  • In split screen, I create one widget for each player, but only the last widget of the last player is beign shown, and gets duplicated for each player, so if I interact with my widget, it will change all the player’s widgets.
  • I got a row of widget class that I create dynamically from an array, is the same issue as above, all the elements that are being shown on the screen are the same (but I print the array and the widget names and are different on the logs).
  • When I play a game and get back to the main menu or other map, some widgets are being overlapped because their visibility should be on hidden (seems that they are not being destroyed properly).

I migrated my project from 4.15 to 4.17 and then, 4.18, and have the same issues on both versions

I also read a lot and seems there is some issue with the Blueprint Compilation Manager (i.e. UMG visibility function broken in packaged build 4.17 ? - Blueprint Visual Scripting - Unreal Engine Forums ). I tried turning off that manager but still have the same issues.

Any thoughts? Please, I will really appreciate any help. I’m stuck with this some weeks and it’s getting really frustrating :frowning:



Not sure if it’ll help, but check the level blueprint and the widget settings in the original blueprint of those widgets and carefully go over those settings.

Just fixed a clipping issue in my own widget for example, after migrating from 4.15 to 4.17. Also keep an eye out for broken links/unknown references.

Yeah, I got some clipping issues too with the new 4.17 clipping system. I set almost everything to “Clip to bounds”, and the clipping problems disappeared, but all other issues are still there

So, I manage to find a workaround to this problem by activating the nativization of some widgets, but since nativization isn’t working on most of my widgets, I cannot solve all the issues, is strange that my widgets work properly with nativization, but without it they doesn’t :frowning:

I was having what sounds like similar issues, upgraded from 4.15 to 4.18 and one of my widgets refused to be destroyed between levels. Enabling nativization (Exclusive) on the widget fixed the issue, so thanks for that suggestion!

One odd thing I noticed was that adding the widget to the ‘List of Blueprint assets to nativize’ and then disabling nativization still works as a fix, it doesn’t matter if nativization is actually enabled as long as the widget is in the list.

I thought maybe it was a bug and the nativization was still happening and ignoring the drop-down setting (I still get a ‘Nativization and fast widget creation is not supported at this time’ warning when compiling the widget), but checking the output logs confirms that’s not true and it is indeed properly disabled.

Perhaps that’ll help you with your un-nativizable widgets?