WidgetDebugger not showing variables in scope.


[Bigger Picture][2]

I also can’t read any floats as well. It’s all Public. Other blueprints have no problem accessing these variables.

Steps to reproduce: Make a public variable in the event graph of a game mode. Then access it from a UI Widget BP. Debugging during runtime will show it out of scope, however all functions will be resolving.

Even if cast every tick, still out of scope.

PS: I didn’t recognize this as a bug and thought that I was somehow at fault. I asked a question, but now I can’t change the category to a bug report. Please delete it. >[Link][3]<

Edit: Ok, it seems that it doesn’t matter if the variable is in scope or not. I have the same thing happening to local variables as well. This only happens in widget debugger.


Hi ,

  • Is this widget a 3d widget or a normal widget?
  • Does this occur with any other variables or is it only local variables and variables called from other blueprints?
  • What steps can I take to reproduce this on my end?
  • Does this occur in a clean, blank project with no additional content or is it limited to one project?

Hi ,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

Sorry for the super delayed reply .

It’s a normal widget
I’ve only tested this with local and outside variables.
To reproduce make a new local variable for a widget. (or outside var and call it in the widget).
Happens in every project I have. Tried in blank, same result.

Hi ,

Local variables showing as out of scope in any blueprint is a known issue, and is currently in our system as UE-2821. I am going to update the bug report to reflect that this is affecting widget blueprints and that additional developers are experiencing this error.