WidgetComponent not displaying true colors

WidgetComponents do not currently display true colors in 4.12.3 and all previous versions.

I have a UMG blueprint that contains an image widget using a pure red material “Color(1,0,0)” so it should display pure red, but it doesn’t. WidgetComponent’s are supposed to and currently aren’t affected by lighting so i assumed the off red was because of post processing but it isn’t because i have disabled everything that could possibly affect color like eye exposure, contrast etc… but still no luck.

See picture below, the left is how it is in-game, the right is what it’s supposed to look like.

Is your material of the right domain?

Yes, the material is a user interface type

Hello AndrewM47,

I was able to reproduce this issue on our end. I have written up a report ( UE-32520) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

This is caused by the Tonemapper post process - happens to everything rendered in the scene.

I search for “Tonemapper” in the post process volume but i couldn’t find anything?

Don’t think it can be disabled or enabled in that way. Probably only disable-able through a cvar or native function, you can disable it in the editor under the Lit button in the viewport, there’s a section on post processes you can disable. Generally the rendering team uses r.* for their cvars, so probably something like r.tonemapper 0, but that’s just a guess.

@NickDarnell It says on the issues page that linked me here that this issue was fixed (sometime after your comments above) - but I’m having this issue in 4.23.1 and 4.24 preview.
Excuse the texture stretching but here’s a quick look at my case. a way to get around this