Download

Widget won't be added

Hi all…
Watch these pics…
http://s17.postimg.org/awacexhl7/Immagine.jpg
http://s30.postimg.org/5ej475zhp/Immagine.jpg
Why i can see only the first image?

please help me ç_ç

hey there,

i would say you probably lost the reference of your widgets, i even wonder why its working with your first widget, but i may be wrong too.

Try the following:

after you call “Create Widget” save the output into a variable and then Add it to Viewport,
do your delay and then "remove from parent via the variable you just set,

do the same thing with your second one.

best regards

save…the output? How O.o

ehm, the “Return value” from the “Create Widget” node is the “Output” i was talking about,

save that one in a variable, thats all what i was talking about :wink:

you mean i can add the widget to a variable? how?

You have to pull off of the Return Value from the Create a Widget box and Promote To Variable. Then you will see a a new variable called New Var so rename it to referance your widget. Hope this helps

I don’t see promote to value O.o

can you explain me how?

please help me

Hey there, first of all, we have a rule here that you are only allowed to bump a thread after 4 days of no response.
Please remember this rule for upcoming bumps! (:

Second, he meant this options:

http://puu.sh/julok/c0c647e341.png

Drag of the return value of the CreateWidget node and release it on an empty space.
Clicking “PromoteToVariable” will create a variable of the Objects Type. Which in this case, is your Widget.

You can then use the Variable to interact with the create widget. But make sure that this variable is filled with
the create widget! If you just create the variable and use it without filling it, it will just be an empty container!
This type of variable is not like an INT, where there is always a number in it! This one can and will be empty
if you don’t fill it! PromoteToVariable will directly add a “Set Node” for that variable and connect it with the
ReturnValue.

http://puu.sh/julCb/f59784638f.png

You CAN and SHOULD use the “IsValid” node on these Pointer variables. The “IsValid” output will only fire if the
variable is not empty.

So try to fix the error with the variable. If this doesn’t work, come back and show us the setup (:

sorry for the inconvenience …
By the way i have still the same problem…
I can see only the first widget…
http://s27.postimg.org/ipdl62p5b/Immagine.jpg
http://s2.postimg.org/67z678dat/Immagine.jpg

You don’t have a delay for your second Widget. everything you have done there will be executed at the end of the tick, so
it will be added and directly removed again.

i set the delay but it doesn’t work

This worked fine for me on 4.8.2 at least

I solved…i changed the map and it works…why O.o?