Widget interaction component issues android


I am having issues with the new widget interaction component on android. I making a 2d game that has clickable buttons in the world. I am using the setup below together with a standard 3d widget that has a button and it works as expected on desktop.

On android however I always need to double tap buttons for a click to happen, the first click always makes the button “hovered” but never triggers the click. The button will be “hovered” until you click somewhere else or tap said button again, which then fires the click event on the widget.

I have used the setup bellow and many different variations of it(touches etc) but it always seem to work like this. Is there something I have missed or is there a bug in the new widget interaction component? Can I turn off hover functionality all together for buttons on device? (Its not really possible to hover with finger anyways).

I am experiencing this on PC platform aswell, have tried:



Have you found a solution to this?

I found a workaround. I check what platform we are running on when the hover event is fired in the widget. If we are on mobile, I manually execute my click function. It gives the behaviour I want, but It’s definitely a work-around.

Alright. Thanks

I had the same issue, for a 2d game with widget in the 3D world. Everything worked perfectly on windows and on the mobile preview from unreal but not on my android device.

I just fix it by using the on pressed event instead of the on clicked event on my button. It now works correctly on windows and on my android device :slight_smile: