Widget Interaction Component doesn't hit widget

I’ve tried using a Widget Interaction Component for a first person character to interact with a 2D widget in 3D world space. When doing this in an empty example project, it works perfectly and very easily. Just throw a widget in an actor, place the actor in the world, add a Widget Interaction Component to the player character, and it just works perfectly “out of the box”.

However, in the project I’m currently working on, trying to add this same simple component just doesn’t work!

I have a widget that already works fine in 2D. I add that to an actor and place the actor in the world, the exact same way as in the example project. I then add a Widget Interaction Component to our player character pawn, just like in the example project. I do every step the exact same way. But even though it works in the example project, it just doesn’t work in my custom project.

When I enable the debug trace for the Widget Interaction Component, I see the trace line being drawn but it never actually hits the widget. When the debug trace works as intended (in the example project), the debug line should stop when it hits a widget, and there’s a small blob drawn at the hit location.

In my project, this just doesn’t happen. The line continues through and behind the widget, and there is no colored dot where the line should hit the widget. And obviously I can’t interact with the widget.

I can’t for the life of me figure out what’s wrong in our project that makes this happen. I’ve tried changing the Virtual User Index and Pointer Index for the Widget Interaction Component but it doesn’t seem to make a difference.

I can’t find any tutorial or anything that adresses this. If anything, people seem to be having the reverse problem, with traces hitting widgets that are supposed to be invisible…

But how do I make the trace hit a widget that it’s supposed to hit?? Please help! You’re my only hope.

TL;DR: Widget Interaction Component debug trace goes right through widget, can’t interact with widget… Why?

I solved it. The solution was to (re)move the giant cat outside of the window. I have no idea how in the hell that had anything to do with hit traces for the widget interaction component, though, but whatever. :stuck_out_tongue:

What was the solution? Having the same problem

I’m actually not sure exactly what the problem was, but I realized that we had an actor in the level that for some reason interfered with the widget interaction. Any time that actor got too close to the widget, it would block interaction, even though the actor’s bounding box wasn’t nearly that big. I believe the specific problem with the actor in question was the NeoFur component, which for some reason had a huge sphere of influence that for some reason blocked widget interaction. I’m not sure why that was a problem, but disabling NeuFur and/or just keeping those actors well away from the widget “solved” (or at least avoided) the problem.

Thanks, I gotta go through the scene to see if there’s some evil things going on :slight_smile:

OMG, ■■■■ ■■■■ etc.

No fat cat but an only visible in editor box that had collisions. Thanks for leading me in the right direction! :slight_smile:

I had an inactive and invisible sphere collision that was overlapping the widget components, best to Show Collision (Alt+C) in your level viewport to check. Thanks