Widget Buttons are touching

I can’t seem to find a spacing option in the UMG editor. When I make User Interfaces in Unity, you can set how far apart the buttons are per panel. I thought that the margin option would solve that in Unreal, but margins just changes the size of the button.

Depending on what kind of “slot” or panel etc. the widget is inside of in your widget structure tree, you can sometimes get “Padding” options near the top of the details panel.

Also, there is a widget called “Spacer” that does just what it sounds like - pushes space between other widgets.

Consider also whether you have Filled or Auto align available for the place you put the widget, and try those.

Also, some layout containers like Grid allow you to assign specific cell widths and spacings and then assign child widgets to each cell.

Which approach is best depends on what you’re trying to make.