Download

WHYYYY do my booleans HAAATEE MEEEEEEEEEEEEEE

For the love of god, why do my boolean variables stop working all the time?

Code that worked flawlessly before stops working because some boolean variable that was working great for years, stopped accepting any changes made to it by SET nodes.

And I know thats exactly whats going on, im not crazy.

Code will execute that is supposed to set a boolean variable to false, and it simply DOES NOT anymore. It did for a long time, I have changed no code.

I am literally pulling my hair out with this engine sometimes.

Are you sure you don’t set the Boolean to True in Tick or any other event?

The only time it is ment to be set to false is when I click a button,

and like i said it worked flawlessly for a long time, now, magically all of a sudden, when the time comes to set the variable to false, any GET node of that very boolean does NOT A ****ING THING.

and my code is so very deep at this point, and I have no choice but to watch it all fall apart and break systematically, as booleans fail one after another., aaaaand its making me flip my ****.

No at no point have I established a tick event that would constantly refresh any or all of my booleans to true/false

At this point im thinking about restarting on a new project in an older version, which is going to take me YEEEEEEEEARSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSS

Im sure problem is in your setup… so you can try to create new bool variable and replace it where you have your old booleans… maybe you have somewhere forgotten setup where you set that bool variable… or show code and i can look at it…

edit: now i read better your first post… do you have older version of your project? true is that this engine is sometimes really buggy… i had crazy problem with standalone play, it always failed but when my project crashed, i launched 1 week old version of my project, copied some uassets to it and standalone magically started working…
but anyway, its very unusual that bool variables can stop working… try to use print string nodes after you change it, it may help you find problem if your booleans are not set correctly

Sounds like a disconnection. Literally. I think one of your nodes has become disconnected. Did you change any Structs? Upgraded the Engine?

Booleans clearly work - sounds like a good oppurtunity to develop you blueprint debugging skills :slight_smile:

Few
useful things
Printout the value in question during tick
Set strategic breakpoint in blueprint to inspect variable
Use find all to search for all “set variable” nodes (make sure to search entire projec not just currenr breakpoint)

Boolean variables only change values if you call set

If this is a bp. Right click the book and find all references of the variable and look for set nodes and see what is going on place a break on them to see when they are accessed.