Download

Why would OpenLevel not work right?

This is my second time hooking up an OpenLevel box, and the first time it just worked.

This time my trigger volume takes me to the PlayerStart of the current level, instead of loading the next level.

Why? How do I fix it?
db4fe981d1521fc4e32aa5d00c6ea09fa0eeaad2.png

Might sound silly. Have you doubled checked spelling and grammar in the level name?

Narg

Are you sure you didn’t accidentally give it the name of the level you’re currently in? That’s the only reason it would put you at the spawn point that I can think of.

I just checked again, and the spelling is right. Perhaps I pulled the new level into the current project in a forbidden way. I used xcopy to transfer all the stuff from the \content directory into a subdirectory of the content directory in my current project.

I tried deleting everything, and did a drag-n-drop from Windows File Manager into the new directory in the content browser. That got my machine very upset. It spewed out hundreds of error messages like this:

LogAssetTools:Warning: Failed to import ‘c:…\Reflections\Content\Assets/Textures/T_WaterTextures_M.uasset’ unknown extension ‘uasset’

I thought you were allowed to drop files into the content browser, but that did not work!

Now I am trying to Migrate from the Reflections project back into my working project… hope it works!

PROBLEM SOLVED!
Migrate was the secret. I wanted to pull the Reflections level into my project, and Migrate did it without error. Once that level was in the project with no errors, the OpenLevel gizmo just works.