why this problem always happened?

An error occurred while trying to generate project files.

Running C:/Program Files/Epic Games/UE_5.1/Engine/Build/BatchFiles/Build.bat -projectfiles -project=“C:/Users/Ari/Documents/Unreal Projects/MyProject3/MyProject3.uproject” -game -rocket -progress
Running UnrealBuildTool: dotnet “…..\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.dll” -projectfiles -project=“C:/Users/Ari/Documents/Unreal Projects/MyProject3/MyProject3.uproject” -game -rocket -progress
‘dotnet’ is not recognized as an internal or external command,
operable program or batch file.

Update visual studio and make sure you have installed all the necessary packages.

Looks like you’re missing some .NET stuff on yoru PC. Did you follow this?

1 Like


So I basically have to generate project files every time I add a new file to my project through VS2022. So I do this alot. Yesterday I did it and it worked fine. Today I am getting this same error. So what exactly did I do wrong here? Why is it suddenly missing a dll?

I’ve updated VS2022 in as many ways as I know how and double checked all the packages on the setup page are installed. But it still gives me this error