Why this double comment and how to remove it

Is there any way to remove the double commenting in blueprints, or rather “how to”. I believe I’ve seen blueprints that were not double commented like this.

It seems pretty weird, I think.

Thanks.

25842-doublecomment.png

Hi KennethMundt,

The top bubble is a scaling comment that is designed to be read no matter how far you scroll away from the original source. Once you scroll in to a specific distance it should disappear from your screen.

Arhhh… There’s the explanation. Now it seems like a good, although, I’m, apparently, never that much zoomed in.

Thank you.

Is there any way to disable the comment bubble? I don’t like it to appear when I zoom out. I comment the blueprints to have reference, not to make them look messy!

Unfortunately no, there is no way to disable this at present without modifying the engine source code.

Can this become a feature as it is extremely annoying when trying to read the blueprints?

yea would vote for that too please

Yes, the bubbles clutter the view. Maybe change the zoom level at which they disappear? For me, if they disappear at a -4 zoom level would work. Right now they do at -2, which is too close. Even better, add an Editor user setting for this threshold value? Depending on the display resolution or size this threshold might be different for each user.

Seconded.

First of all, it appears way too early. It appears at Zoom level 3, but the text in the erroneous extra bubble is smaller than the normal text. So you have extra text that is actually harder to read than the normal text.

Second of all, when you zoom out very much, the erroneous extra bubble becomes enormous and completely obfuscates the blueprint.

I honestly can’t wrap my head around this feature’s existence, let alone the lack of control over it. Please remove this or let us remove it ourselves, PLEASE. It makes comment boxes totally unusable.

EDIT: Here is a demonstration of how perplexing this feature is. I challenge you to justify its existence after looking at this shot.

I’m working on learning the engine and trying to use comments to note how everything is working in the blueprint. My comments are way longer than what’s in the image above (like a paragraph) so yeah, this is really cluttering up my blueprint also. I can’t believe you can’t disable the comment bubble right now…

Agreed. This isn’t helpful at all. In fact makes my blueprints much harder to see when zoomed out.

It would probably be great for high-dpi screens like 4K, but on 1080p, it’s just a waste of space.

If I could disable these bubbles completely, I’d do it in a heartbeat & never look back.

I agree, the bubbles obscure too much and become messy very easily. Would love to have an option to remove them.

Would love to hear a justification for this. It’s annoying enough that I’m avoiding using comment bubbles now.

It could be easy for the devs to add a simple setting for controlling the zoom level at which they appear.

It would be great to see toggle and pin like for the node comments:

http://i.imgur.com/dyyegSb.png

Unbelievable. I cannot understand why this even exists and why it hasn’t been at least trimmed and fixed. Please, Epic fix this if you choose to push Blueprints on us all.

I’m in shock too - thought I just couldn’t find the option to turn it off.

Count me in, bubbles are horrible!

Comment bubbles are still present in UE 4.17.
They’re redundant, imo. They’re just parroting the text below it.

I searched the Editor Preferences for the words “comment” and “bubble” and I can’t find anything. Please add a feature to disable them. Thank you.

I totally agree!

Add me to the list wanting this enhancement request

I agree; if being able to choose the zoom level is too hard, just allow us to disable them! PLEASE! I comment extensively, but this penalises me for doing so!