Why pivot point is not correct?

Why when I import mesh, the 0 0 0 of coordinates (x, y, z) become a pivot point and UE4 ignore real pivot point of mesh? This problem appears only with meshes which are not placed on 0 0 0 of coordinates - I have very much so meshes (a few hundreds), so, it’s not possible to change placing of each manually.

How to import mesh with correct pivot point?

When I import the same FBX into Blender or Unity - pivot point is on it’s place not on 0 0 0 of coordinates.
Both meshes are here: fir-trees
Thank you very much.

Unreal always uses 0,0,0 as the pivot point of a mesh on import. But you could uncheck “Transform Vertex to Absolute” so your current Pivot Point should be zeroed out.

Great! It works! But now all meshes are laying down because there is -90 on X axis - is any method to fix it while importing? Thank you!

You can change the rotation and translation on import.

Thank you so much! But I was trying to change it and it did not make any changes! I putted 90 on X axis there - nothing changed! I don’t have idea why - did you import my tree by this way and it imported correctly?

Sorry that was my mistake. You can’t change the rotation if you uncheck “Transform Vertex to Absolute”. What 3D Software are you using ? In Maya you could just import all Meshes and set them to zero and then re-import everything to unreal.

I use Blender and I have around 500 meshes - I don’t have idea how to re-import them all not manually. But if it’s more easy to do it in Maya - tell me the method step by step please.

I did in maya but cebyer pivot freez transform and whn exprt to fbx in ue4 pivot alwaya not in center plus there is transformation values which i dont hav in maya plus in maya pivot all center too