Why physical animation bug on a character blueprint?

here is the video - YouTube

The one behind is created as an ACTOR blueprint, physical animation is fine (physics are played on all upper body bones)

The other guy in front is a CHARACTER blueprint with the movement component and here is the result: chaotic physics !

Why ? is the movement component disturbing the physics?

They have the same graph behavior, the same physics asset, the same skeletal mesh, the only difference is their class type one is actor, one is character


or i missed something to copy from the working one?

Can someone try to do the same? (i used the skeletal mesh in the content examples 4.2 project in the Physical Animation level)

Hi skeleton,

Can you give me your physical animation asset? We would be happy to have a look!

■■■■ i am stupid, i dont know why but before sending you my mistake file i just double checked all the things and… the chaotic physics was due to the collision preset i had “CharacterMesh” Preset which set Collision Enabled to “No physics collision”

So changing it to Physics Actor (or customize it) to Collision enabled resolve the bug :slight_smile:

All is fine now !

Thanks :slight_smile: (for forcing me to double check :o)

■■■■ i am stupid, since you ask me to send you the asset i just did a double check and… found the solution… my bad… here it is:

On the skeletal mesh Details panel go to collision and TRIPLE CHECK that you have in the collision preset details the “Collision Enabled” to “Collision Enabled” !!

You can choose Collision Presets to “Physics Actor”

When we create a Character BP the collision preset of the skeletal mesh is set to “Character Mesh” by default and “Collision Enabled” is set to “No physics Collision”

Thanks for asking me the files, so i had to triple check my errors :slight_smile: