Why my UV mapping is lost when i import Rhino file using Datasmith?

Whenever i import a project from Rhino using Datasmith, it removes all my texture mapping and replace them with 3 default channels generated by Datasmith.

Even if i turn on multiple mapping channels in Rhino, UE still creates its 3 channels after removing mines.

1- Has more bricks
2- Wrong mapping

Anyone? please guys I need help…

I’m facing the same issue. Is there any news on this subject? Or workaround?

Same here. I guess no one at Unreal is interested! 18 months later.

It’s because of the UV of NURBs system, try to convert your object into MESH before using Datasmith.

That did the trick. Thanks for the tip.

Just as a note, if you’re running a Dataprep asset to pre-process the Rhino file, you can tell the importer to use Rhino’s mesh instead of Unreal Engine’s own tesselation, this way you don’t need to maintain a bunch of meshes in Rhino. In the Dataprep editor, under Inputs, click the gear icon next to a Rhino input and under Geometry and Tessellation Options, change Geometry to ‘Import Rhino Meshes and UVs’.

Unfortunately this does NOT support Rhino features like rounded corners, shut lining, thickness and curve piping.
Would be really really nice if Epic were able to fix this, but Rhino’s brep geometry has always made UVs difficult when sharing with other software.