Download

Why my physics objects fall to the ground so slow?

Hello,

When I turn on the physics, objects fall to the ground very slow/ What to do to make them fall more realistically? Like something heavy, not so light. How to handle the physics in UE4?

: ) this is an interesting one. By the way have you noticed how in almost every game were you have live physics they seem to be floating or light weight (best example ragdolls), such as when a brick collapses it just seems to fall like a fake Hollywood set piece cardboard?

That is because of the nature of the physics engines and implementations with their default settings. It is the same using physX in max or Dynamics in Maya until you change the settings and even then you will run into unsatisfactory results. The way around this is to increase gravity not just Mass per object. For best results however if its a scripted sequence is to bake it out in a 3d app and then try best to get what you want out of the sim by manually adjusting keys to give the required results if the settings aloe weren’t enough. In unreal try increasing gravity, I don’t remember if you have the option for that somewhere also make sure you are working in correct scale as much as you can.

yes, it’s weird. I play with settings in World Settings -> Physics -> Global Gravity Z : -5000 seems OK. Thank you.

Changing the Gravity is just a hack. a Physics Engine should simulate actual physics. Which means the MASS should be taken into account. It never does though.

In the real world mass has no impact on how fast objects are falling. It may feel counter intuitive, but all objects fall at the same rate regardless of their mass.
What does make a difference is drag or air resistance, where some objects, depending on their shape and density, will interact differently with the “air” they are falling through.

So if you want your object to fall faster, I’d say play with the linear and angular damping.