Download

Why my character is going beyond the capsule component during animation?

Hello everyone. Trying to make evade function, where character is doing a backflip. I have added root motion animation in state machine and created transition rules. But when I activate it, my character is making a backflip, camera is following capsule component, but character is going out of it and snapping back.
Here’s the video with problem:

And character bp, where I call evade:

I don’t know much, but the animation seems to be imported directly. You may need to somersault in the character’s position and reposition the capsule component while you jump backwards. I’m not sure, it just seemed that way to me.

I did that earlier, but now when I using montage instead of usual animation, cupsule component is moving too. If it will work correct, it will much better rather than calculate distance of capsule translation. Problem - I don’t know, where I can find parameter, that affects the distance.

I don’t know much either, but I think you have to enable root motion for that animation. Root motion will drive the capsule.

It’s enable by default (

There’s another setting in the ABP if I’m not mistaken, I’m not at my computer. Check that. Allow root motion, something like that.

Search for “Root motion mode”.

Find only root motion mode in ABP.

That’s it.

OMG, it’s work! Just find 2 ways to fix it:
In ABP “Root motion mode” - Root motion for everything
изображение_2022-01-08_203959
Or
in animation - “force root lock” works too.
изображение_2022-01-08_204103
Thank you very much!

Your welcome.
I just happen to know this because I’ve been thru this.
I’m fairly new to Unreal, I’ve never used that second option.