Why might my AI not be moving using NavMesh?

I have a simple A.I set up using a NavMesh. When I use the Example Map it works fine. However, on a different map, I am using a landscape. I can use the same enemy bp and it does not move at all. It does all of its other function that I have set up but it will not move. Any ideas?

Do you have your Navmesh visible (push P for shortcut)? If so what does it look like? if you are using the landscape to build on you may have to look at your navmesh settings.

I tried it a while back and remember you have to tweak it some to work properly.

Yeah the the ground is green. I have it setup the same way as the Example map and it works there. I also tried creating a flat box geometry and put navbounds on there and it still didnt work. So I dont think its the landscape. But without changing anything it works fine on the Example map.

if possible can you post up a screen shot ?

RIght now in 4.2 simple move to is bugged and don’t work.


Would you be able to post an image of your BP setup so that we may take a look?


This is the setup I am using to get the AI to chase the character.
I have found that on the landscape, the AI falls through the floor, then moves towards me, only reason I know he is moving without seeing him is that I have him shooting a projectile at me. So I guess it is working to some degree, but now I have to figure out why the actor is falling through the landscape.

you might just need to set the capsule collision to work with the terrain, and Simple Move to Actor is bugged in 4.2 and will not work until they release 4.2.1 with the fix(confirmed fixed)

Thanks for the information. I shall wait for the update!