Why isn't the ART tool showing an bones in list?

I have created skeleton, posed it etc. Now I’m at skinning part. I have used Smooth Bind in Maya, and Dual Quaternions to bind skin. Bones are properly skined to mesh.

But ART tool, doesn’t show any bones in Influence List.

Any ideas ?

Ah, never tried using DQ skinning. It’s possible the query to find influences using the skinClusters doesn’t work properly with DQ skinning. Have you tried using linear skinning? UE4 does not actually support DQ skinning, so I’m not sure you’d be able to import your asset properly using that method.

I tried classic linear, and it still didn’t worked.

But, DQ import just fine into UE4.

If that’s any help I can upload the troubling assets for you. Including templates, and maya files, to dropbox.

that would help tons!

I had the same problem, at the moment you smooth bind your mesh, go to the tool options and UNCHECK the "Remove unused influences" box, it’s checked by default. I suppose that if your default skeleton doesn’t bind any mesh, or another bone binds (for example) an entire limb, the other bones down the hierarchy gets lost in the process of binding the bones with the mesh… Just my 2 cents, worked for me, hope it does for you. Cheers!