Download

Why isn't my animation smooth?

Hi,
i follow a video and created a Blend Space with direction and inside that Blend Space everything works perfect. But while testing it’s like Idle -> Run, there isn’t any smooth transition from Idle to Walking and Running. I guess it might work with a Controller but not with a Keyboard.

I would like to make the character move like in Assassins Creed. Idle -> Starts running -> runs.

Well to start any tutorial more than 6 months old is usually out of date and you can also in most cases add the “official” documentation that is not always current. To get the kind of result you are looking for depends on how you have your migration path set up in the animgraph so a screen shot would be of help but as you see once in a state via a blend space it just works so that will never be an issue as to smooth animations. Where the problem is persistent is how to get into and out of a state by using a form of a switch going from one blend space to another where the blend weight can be changed to account for the required ease in and ease out.

Blend by int is a good example of a nod that can switch the migration path based on the desired state change, going from a run to a walk for example, and at the bottom of the nod will be settings that you can change to the desired ease in/out.

Another option is you can include all of the locomotion states with in the same blend space and since it’s all with in a single state will produce smooth animations but can tend to paint your self into a corner by adding to many levels with in the same state machine.

I have a idea, can i make a graph with “acceleration over time” ? So when i press W hes starting going from idle to walking, like in GTA for example, when you press W he doesn’t instantly walking, but he does it slowly. I need to modify the speed on “W”. it’s basicly “Walk (on/off)” and i need to make when “w pressed” increase from 0->300 in 1s for example.

Any idea which node could help me ?

Hey, I’m a little late to the party but if it’s helpful you can set the Horizontal/Vertical intep in the axis settings in your blend space.