Why is unreal wanting to use forward slash in my directories?

I Dont know if my first question went through or not. However, I found a unique issue.
Here is my system:
i7/12gb RAM/1.5TB HDD/ Win10

this is the error i am getting
Failed to copy “C:/Program Files/Epic Games/4.8/Templates/TP_ThirdPersonBP/Config/DefaultEditor.ini” to “C:\Users\Documents\Unreal Projects\MyProject/Config/DefaultEditor.ini”.

I noticed that Unreal is wanting to use Forward slashes to read(copy) and create folders. Is there a way to correct this? Thanks for any help!


It’s not unique. I got the same problem.

Interesting. I hope someone post a fix. Its really annoying :frowning:

I just created a folder for the name of my Project with the way they wanted and it worked just fine. Hope this helps!

Unfortunately it did not work. :frowning:



bump againnn

This recently happened to me, and luckily I was able to find a fix.

I was creating a virtual override function in a PlayerController header file and tried to use VS’s create declaration tool, but I believe since this function was an override it actually created a new and separate .cpp file for this class (which I am sure confused UE4). I found the file and deleted it, and the problem went away.

Seems to be more of a Visual Studio problem rather than UE4 bug. But I learned my lesson to be careful when using auto declarations. Hope that helps!

same issue