Why is UE4 only recognizing a limited number material ids on my imported mesh?

Just to be clear, you are using a multi/sub object material with 6 different materials in it and each with a unique name, right?

Hello! I am importing buildings from 3ds max into Unreal 4, and I have been able to solve some problems except for one: No matter what I do, unreal only recognized 3-4 material ids. On my buildings I have at least 6 material ids. the first instance is one one building of mine where I had 5 materials, but it only showed 4. And the 4th one combined 2 other material id resulting in a grouped part of the object with a singular material where there were supposed to be 2.

I decided to move onto another building thinking it was the way I set up 3ds max. I had 6 material id’s this time, but only shows 3 in Unreal. I read up on it a bit and assumed that perhaps I needed to make a multi sub object. So I made one and added some place holder textures. Nothing changes. Any Ideas?

Hey that was quick :slight_smile: yes, I am using unique names

like this? there are no duplicate names in the outliner.

sure thing, just a moment

it worked for the cube…all 6 ids

Ok, now make sure no material, texture and mesh share the same name. Also you dont need to export the textures inside the FBX so you can get rid of them and use placeholder colors in the materials for now to make things simpler.

Well that’s strange then. :\ I recently imported a skeletal mesh with 18 materials with no problem.

Can you try to recreate this with another mesh? Something simple with 6 material ID’s would be fine and if you get the same result then upload the Max file somewhere so that i can take a look.

OK, so I tried something different. I attached all of the pieces of the mesh together and it shows all of the ids! It worked for the cube because it was one mesh already. Thank you for your help :slight_smile:

I just had this happen to me and after a couple hours figured out if I have multiple material slots in blender but they aren’t assigned to faces they either don’t get exported or imported. In my case I created multiple vertex groups, but forgot to assign any faces to the second material.

Obviously not the solution in your case but this might help someone else.

I also just ran into this, for a work around, you can select all the faces you want to apply the material to, and change its ID under ‘Material ID’s’ (such as 2, 3, 4 etc), once youve done this then slap the material on top of the selected polys, hope that helps.