Why is UE looking on the D:\ drive? It's causing crashes

As the title says, I’m getting assertion errors for files located on the D:\ drive, but my install is plain vanilla C:\ drive.

Assertion failed: … [File:D:\build…

Hi @teqteqx, the D:\ is Unreal Engine internal cache drive .

The real error is the words after the assert something like value != null or some other message often this is because some content has not been correctly converted from a previous version like the image file size is shorter than the registered image details.

When asking for help you need to get the full message, however it is unlikely that even, when we read the comments in the source code, we will know what the problem or the file name is.

Are you using the Binary Epic Launcher version?

Did the problem occur in a version before version 5.0.3

Was your Project converted from a previous working version.

Have copied in content directly to 5.0.3 without conversion.

In that case use the import function on an blank new project to get a new converted version and see if this fails.
Asserts are because the input crashing parameters have been checked are wrong and this is stopping the Engine from a crash


1 Like

The filename the error is occurring in is the source file on the computer that the engine was built on. It’s completely irrelevant to the error message itself, only useful if you’re trying to track down where in the code the error is occurring.

The rest of the error message will be necessary to have any idea what the problem is.

1 Like

@Jimbohalo10 , @eblade thanks pals for the replies…

UE 5.03, Windows 10 fresh install, RTX 3060 12GB, Dell T5600 with 64GBs ram and dual Xeon CPUs E5-2689 2.60GHz

Bummer, I was hoping that could have fixed a bunch of crash reports I’ve seen.
The actual file location should really be used, as that is much more informative (imagine an install on a second HDD, that was giving errors).

The ValleyoftheAncients and CitySample demos crash in VR Mode. Everything else works fine. I know these are large models, so I’ve been trying to adjust settings for that… but AncientWorlds worked once just fine (actually several times it loaded and I explored and used actions in the VR Preview)… so its a mystery why its not working now. Here’s one of the error messages… they all seem to be “assertion failed” errors on various files… thus my hope it was location issue. Thanks

Assertion failed: ColorRT [File:D:\build++UE5\Sync\Engine\Source\Runtime\RHI\Public\RHIResources.h] [Line: 3333]

If you built the engine on that computer, then it would be the path that you built it from. The path is built into the binaries when it’s built. That’s … pretty much how error messages from native code work :slight_smile:

You can reference directly to the source code https://github.com/EpicGames/UnrealEngine/blob/d9d435c9c280b99a6c679b517adedd3f4b02cfd7/Engine/Source/Runtime/RHI/Public/RHIResources.h#L3333

Somehow you’re getting a null texture into RHIRenderPassInfo.

No idea what would cause that.

That good… I thought @Jimbohalo10 meant it was Unreal’s drive during dev… but he said "the D:\ is Unreal Engine internal cache drive "… so is that something I can change? I already have a D:\ drive and that could be the problem. I see other people with D:\ drive assertion errors in my first Google search, so its not just my machine.

Again, it works fine on smaller models, but maybe they are not calling this particular file. I tried using Repair on the install wizard to no avail, and reduced my resolution and the “viewport screen percentage” as the intro screen suggested on lower spec machines, to no avail. I may have to reinstall UE, because it was working for a bit. Also, it runs for about 2 seconds before crashing.

Hi @teqteqx,
I think you need to add a very large page file of virtual Memory like 128GB on your NV ram solid state system disk which I documented in another post

Install Pagefile.sys on Windows 10
In the size box type 128000 in both boxes
Then restart your PC.

There was a problem with C++ and Nanite content which crashed with an assertion and this fixes many problems.
If it works and you want to save space on the SVRAM disk then you can cut the value down but remember that other files may be bigger and will cause problems

My guess is that something in the model data is corrupt/invalid, and just blowing up the renderer trying to render it. Although out of memory conditions can cause bizarre issues, so Jimbohalo10’s idea might not be a bad thing to try.