Why is this happening? My interface flickers everytime i hover my mouse over a button

I dont get why this is happening, when i was on windows 8 back then it was fine now it does this when my laptop reverted to windows 7. my os is 64 bit, 2gb ram (i know it’s low but it still works) intel graphics 1gb memory, and i3 core. this lscreen flicker is very annoying and i cant focus working. please help how to get rid of this

Hello PeteSingers,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. Does this issue reproduce the 4.16 preview?
  3. Have you made any changes to the widget reflector?

Hello PeteSingers,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.


I tried screen capturing the anomaly itself but it won’t show up. The interface/window flickers with random lights, grains, stripes, and sometimes even blacks the entire UE editor out. Only happens when I hover over a button when a tooltip shows up. I tried lowering all possible graphic settings and nothing happens.
I know my laptop isn’t supposed to run on it with only 2GB RAM but I have worked with UE ever since even if it’s lagging, I used UE for my thesis project too. But that was a 4.10 version, maybe the problem is with the new update (4.15).

what’s the widget reflector? I’m not familiar to it sorry. please explain

The widget reflector is meant for editor development and not intended for normal use within the engine. There have been others who have run into issues while trying to use the widget reflector to scale their editor UI. Some of the issues have been similar to the issue that you are seeing in your project. The widget reflector can be found by navigating to Window> Developer Tools > Widget reflector (example below).


so to what value should I set it at?

so I was able to get a screen capture of the anomaly using my Garena screencap. This is what happens

I also tried changing the values of that widget reflector, nothing changes.

I noticed that your scalability settings are all set to “Low”. Could you try turning these up and let me know if this makes a difference?

no it doesn’t make a difference, and if difference you mean better, no. but it does makes things a lot worse.

So I tried removing the Aero theme in windows 7 and nothing changes, i thought it was the problem but i was wrong.

Could you try opening the same project on a computer that meets the recommended specs and let me know if this issue still occurs?

Link: A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums

I meet the specs except for the RAM, I only have 2 GB. But like i said in past experiences this didn’t happen and Windows 8 took more RAM than 7 so my pc performs better than it did when it was on windows 8. I’ll buy extra 4GB RAM soon and I’ll just update you when the problem still persists. I can work well though it just bothers me why this is happening and why I’m the only one experiencing this.

Forget about it, I had the same issue when I tried 4 years old win7 laptop with integrated video, which is the problem, your case is probably same, just old video drivers and they won’t do anything about it.

Even if they can eventually find an issue and fix it, it doesn’t worth the time investment.

you mean drivers for my graphics card or for UE4?

I have the same issue as well